Faire un calcul à partir de nom [Résolu/Fermé]

Signaler
-
 didier28 -
Bonjour, je souhaite faire le calcul de plusieurs cases en "B2", sachant que ces cases ne sont pas toutes remplies, et que celles qui le sont, ne le sont pas avec des chiffres mais avec des noms. En fait je veux comptabiliser les noms de trois lignes dans une case.
Les noms sont différents à chaque fois bien sûr. Est ce possible ???

merci de votre réponse
cordialement didier



1 réponse

Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
62
Bonjour ,

Qu'entends tu par "comptabiliser les noms de trois lignes" ?
On peut concaténer des noms , on peut trouver le nombre de fois où les noms apparaissent, mais on ne peut pas additionner des lettres.


Il n'y a pas de meilleures explications que le fichier en lui-même.
N'hesite pas à nous déposer un fichier test , avec quelques lignes et le résultat escompté.

Pour le poster :

Allez sur ce site : https://www.cjoint.com/
Clic sur parcourir,
Cherche ton fichier,
clic sur ouvrir,
Clic sur "Créer le lien cjoint",
Copier le lien,
Revenir ici le coller dans une réponse...


Cordialement,
Nos seules limites sont celles que nous nous imposons nous-même.
La politesse et un merci ne tuent pas. Il existe un bouton pour "Résolu" pour confirmer que     votre problème n'en est plus un. Fahora
http://www.cjoint.com/c/FFxkNq7NPYb
voici le lien, ce que je veux donc, c'est par exemple, comptabiliser en "B36", les noms qui se trouvent sur les lignes 34,35,36.

par avance merci
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
62
Encore une fois , qu'entends tu par comptabiliser les noms ?

Le terme comptabiliser est relatif à la comptabilité ... Ce qui n'a strictement rien à voir avec des noms...
en B36 dans ton fichier joint j'ai : 5 ... De plus ton fichier est corrompu... Donc il va falloir une sérieuse explication avec des termes justes pour qu'on puisse t'aider.
comptabiliser, c'est tout simplement compter les noms, et pour l'instant je le fais manuellement, mais j'aimerais que cela se fasse automatiquement (ex : un nom = 1, deux noms = 2, etc, )

cordialement didier
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
62
D'accord ,

dans ce cas , il faut procéder :

En B36 :

=NB.SI(C34:W36;"<>"&"")

Tu peux copier cette formule et l'appliquer a tous les autres cellules de naissances.
merci Fahora

cordialement didier