Crée une macro excel [Résolu/Fermé]

Signaler
-
 cookieslite07 -
Bonjour, j'aimerais savoir comment créer une macro excel. Je m'explique, j'ai des valeurs stockées dans toute la colonne F sauf F1 pour le titre du sujet et en fait j'ai besoin de récuperer certaines infos dans les cellules. J'ai deux possibilités soi j'ai une réponse me disant NO BRASS ou sois j'ai un numéro de prise (ex: G1/0/1 jusqu'à G3/0/48). En fait, l'idée est de récupérer les informations "NO BRASS" pour afficher dans une autre feuille de style par exemple 'SOMMAIRE' que ces prises sont disponibles et à l'inverse le reste est non disponible. Je ne sais pas si vous avez compris mais je vous remercie d'avance.

1 réponse

Messages postés
12645
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2020
2 008
Bonjour

1) Pas forcement besoin d'une macro, des formules peuvent suffire

2) Pour t'aider c'est mieux d'avoir un exemple de ton fichier, tu le telecharges sur le site cjoint.com, tu fias créer un lien, tu le copies et tu reviens le coller ici dans un prochain message

Cdlmnt
Via
Messages postés
12645
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2020
2 008 > cookieslite07
Si tu veux retourner des infos d'autres colonnes tu recopies la même formule
=SI(LIGNES($B$2:B2)<=MAX(Sheet1!H:H);INDEX(Sheet1!B:B;EQUIV(LIGNES($B$2:B2);Sheet1!H:H;0));"")
en modifiant les parties en gras pour adapter à une autre colonne

Bonne journée également
Via
>
Messages postés
12645
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
16 septembre 2020

D'accord merci ! juste une petite question si je change la prise 1.03 par exempel et quelle devient plus NO BRASS le fichier le garde quand mêmesur la feuille de style 2
> cookieslite07
En fait, mon SHEET 1 s'appelle SOMMAIRE et mon sheet 2 ce nomme BAIE AT10
le sommaire est l'endroit ou il y a les noms des prises et l'autre est ou il y nos deux colonnes B et F
> cookieslite07
Mon problème est résolu merci pour ton l'aide !

Au pire que ça retourne que les prises et à son port correspondant qui sont disponibles (je rappelle disponible = NO BRASS)