Fonction Excel moyenne mensuelle selon la date

Fermé
Signaler
Messages postés
1
Date d'inscription
mercredi 18 mai 2016
Statut
Membre
Dernière intervention
18 mai 2016
-
Messages postés
17714
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 décembre 2021
-
Bonjour,

Je m'explique, je souhaiterai trouver une fonction me permettant de faire une moyenne de valeur selon le mois où elle se trouver.

ex :
01/01/2014 - 5
05/01/2014 - 25
08/01/2014 -32
07/02/2014 -24
09/02/2014 - 26
....
J'ai un grand nombre de valeurs et il me faudrait donc une fonction que je puisse appliquer automatiquement me permettant de trouver la moyenne (5+25+32)/3 pour le mois de janvier, la moyenne (24+26)/2 pour le mois de février, etc.

Merci d'avance pour votre aide.


1 réponse

Messages postés
17714
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
8 décembre 2021
4 863
Bonsoir,

exemple tes dates sont en colonne A de A2 à A30 et tes valeurs en B
=SOMMEPROD((MOIS(A2:A30)=1)*(B2:B30))/SOMMEPROD((MOIS(A2:A30)=1)*(B2:B30<>""))

tu peux mettre le mois critère dans une cellule exemple pour janvier saisir 1 en cellule D1, la formule devient
=SOMMEPROD((MOIS(A2:A30)=D1)*(B2:B30))/SOMMEPROD((MOIS(A2:A30)=D1)*(B2:B30<>""))