Formule Excel

[Résolu/Fermé]
Signaler
Messages postés
8
Date d'inscription
mardi 10 mai 2016
Statut
Membre
Dernière intervention
19 mai 2016
-
Messages postés
8
Date d'inscription
mardi 10 mai 2016
Statut
Membre
Dernière intervention
19 mai 2016
-
Bonjour,
J'aimerais trouver une formule qui dit que si la cellule "différence d'évaluation" est = à OUI alors dans la cellule "si oui écart" il fasse la différence entre J4 et J5 (en valeur absolue) et si NON dans la cellule "différence d'évaluation", il mette rien ou 0 dans la cellule "si oui, écart"

Merci d'avance pour vos réponses :)


3 réponses

Messages postés
26239
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2021
6 090
Bonjour

on suppose que votre formule commence en ligne 4?


=SI(K4="oui";ABS(J4-J5);"")

renvoie une cellule "vide" si'il n'y a pas oui en K, ,sinon nla valeur absolue de J4-J5
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
mardi 10 mai 2016
Statut
Membre
Dernière intervention
19 mai 2016

Merci beaucoup :) et pour que la formule s'applique a tout la colonne de la cellule comment je peux faire ?
Messages postés
26239
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2021
6 090
il suffit:
_de sélectionner la cellule
_de pointer en maintenant le clic sur le petit carré noir en bas à droite de cette cellule
_et tout en maintenant, glisser vers le bas sur la hauteur utile

ou alors
_de sélectionner tout le champ
_d'inscrire dans la barre de formule la ,formule qui correspond à la 1° cellule en haut
_de faire enter en maintenant la touche ctrl enfoncée

Si votre champ est très grand, vous pouvez le sélectionner au clavier:
_placer le curseur dans la case adresse à gauche de la barre de formule
_inscrivez au clavier les limites du champ (ex C2:C20000)
_ touche enter
et ensuite voir opération précédente

crdlmnt
Messages postés
8
Date d'inscription
mardi 10 mai 2016
Statut
Membre
Dernière intervention
19 mai 2016

Merci beaucoup Vaucluse j'ai réussi :D
J'aurai une deuxième question... J'aimerai trouver une formule avec "SI" qui dit que si les 2 chiffres sont pareils dans la cellule "Appréciation" qu'il mette un NON automatiquement dans la cellule "Différence" et si les chiffres ne sont pas les mêmes qu'ils mettent un OUI
Je voit a peu près la formule mais je ne sais pas comment traduire le fait que les chiffres soit les même ou différents. J'ai mi un exemple dans la capture pour mieux comprendre

Merci d'avance ! :)

Messages postés
26239
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 octobre 2021
6 090
Bonjour

=SI(ET(J4="";J5="");"";SI(J4=J5;"oui";"non"))

le début de la formule sert à afficher une cellule vide si les deux cellules de J sont vides
(sinon renvoi oui sur tous le champ avant remplissage)


crdlmnt
Messages postés
8
Date d'inscription
mardi 10 mai 2016
Statut
Membre
Dernière intervention
19 mai 2016

Merci de ta réponse mais petit problème il me met ca ;
Messages postés
811
Date d'inscription
jeudi 24 septembre 2015
Statut
Membre
Dernière intervention
6 novembre 2020
66
Cela veut dire qu'il y a une "validation des données" dans cette cellule.
Messages postés
8
Date d'inscription
mardi 10 mai 2016
Statut
Membre
Dernière intervention
19 mai 2016

Ah oui en effet j'avais oublié ! Ca marche merci beaucoup :D