Formule en si pour tranche d'age

Fermé
chrisarthur
Messages postés
13
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
17 août 2016
- Modifié par chrisarthur le 13/05/2016 à 22:32
chrisarthur
Messages postés
13
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
17 août 2016
- 14 mai 2016 à 11:30
Bonjour,

J'ai un tableau avec les données du personnel puis une colonne tranche d'age sur laquelle je dois créer une formule en relation avec les colonnes de K3 à L8 qui définissent les tranches d'age afin de définir la tranche d'age.
Mais je bloque sur la formule qui m'affiche une case vide avec :

=SI(H2<L4;"18 à 24";SI(H2<L5;"25 à 34";SI(H2<L6;"35 à 44";SI(H2<L7;"45 à 54";SI(H2<65;"55 à 64";SI(H2<66;"65 et +";""))))))

Et je ne comprends pas pourquoi????
Merci de votre aide dans la compréhension de mon erreur ;-)

Bien cordialement
Christophe
K L
18-24 18
25-34 25
35-44 35
45-54 45
55-64 55
65 et + 65
A voir également:

4 réponses

eriiic
Messages postés
24446
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 septembre 2022
7 128
13 mai 2016 à 23:24
Bonjour,

Merci de déposer le fichier xls (réduit au nécessaire et anonymisé) sur cjoint.com et coller ici le lien fourni.

eric
0
Chrisarthur
13 mai 2016 à 23:33
Merci Eric et voici :

http://www.cjoint.com/c/FEnvG5UIv8z
0
chrisarthur
Messages postés
13
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
17 août 2016

13 mai 2016 à 23:37
Voici le lien avec le document :

https://www.cjoint.com/c/FEnvG5UIv8z

Merci d'avance de votre aide
0
JvDo
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
850
Modifié par JvDo le 14/05/2016 à 00:50
Bonsoir,

si tu veux absolument garder tes SI à répétition, il te faut ça :
=SI(ANNEE(H2)-1900<$L$4;$K$3;SI(ANNEE(H2)-1900<$L$5;$K$4;SI(ANNEE(H2)-1900<$L$6;$K$5;SI(ANNEE(H2)-1900<$L$7;$K$6;SI(ANNEE(H2)-1900<$L$8;$K$7;$K$8)))))

sinon, tu peux utiliser :
=RECHERCHEV(ANNEE(H2)-1900;$L$3:$M$8;2;VRAI)

avec, en $L$3:$M$8, la table de correspondance age/classe d'age.
En première colonne : 18, 25, 35, ... et en deuxième colonne : 18-24, 25-34, 35-44, ....

cordialement

PS : H2 contient le nombre 20520. 56 n'est que le résultat d'un format d'affichage. C'est pourquoi il faut utiliser ANNEE(H2)-1900
0
chrisarthur
Messages postés
13
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
17 août 2016

14 mai 2016 à 01:14
Merci beaucoup je vais essayer ;-)
0
chrisarthur
Messages postés
13
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
17 août 2016

14 mai 2016 à 01:16
Génial ça marche
Merci beaucoup JvDo
0
chrisarthur
Messages postés
13
Date d'inscription
dimanche 22 mai 2011
Statut
Membre
Dernière intervention
17 août 2016

14 mai 2016 à 11:30
Bonjour,
dans ce même tableau je dois désormais renseigner la colonne J avec les impératifs suivants :

1)Si E2 est inférieur à 1000€ alors suivant le lieu de la ville en en D2 le calcul sera basé sur le tableau de K10 à L13
2) Si E2 est égal ou supérieur à 1000€ mais inférieur à 2000€ alors le montant sera calculé à 4,5% de E2.
3)Si E2 est supérieur à 2000€ le montant sera calculé à 3% de E2

J'ai commencé ma formule comme ça :

=SI(E2<1000; ET(SI(D2=Lille;"$L$10";SI(D2=Nice;"$L$11";SI(D2=Paris;"$L$12";SI(D2=Strasbourg;"$L$13"))))))

Mais ça ne fonctionne pas et je suis un peu largué....

https://www.cjoint.com/c/FEnvG5UIv8z

Y aurait-il une bonne âme pour m'aider ?
Merci beaucoup
Cordialement

Christophe
0