SOMME par jour de la semaine EXCEL

Résolu/Fermé
Signaler
-
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
-
Bonjour à tous,

je souhaite faire une somme de mon chiffre d'affaire en fonction de la vendeuse et du jour de la semaine.

Est-ce qu'une bonne âme pourrait m'aider? :)

Colonne A: la date
Colonne B: le nom de la vendeuse
Colonne C: le chiffre d'affaire.

J'aimerais donc savoir combien est-ce que la vendeuse X a vendu les mardi , les mercredi, etc...

Mille merci pour celui/celle qui pourra m'aider.

Bonne journée

2 réponses

Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
Bonjour
pour un champ à traiter de ligne 2 à ligne 100 à adapter (les n° de lignes dans les adresses sont obligatoires avec ce code)
=SOMMEPROD(JOURSEM($A$2:$A$100;2)=1)*($B$2:$B$100="nom")*(C2:$C$100))

1° item JOURSEM(champ;2)=1 pour lundi =2 pour mardi etc...

2° item le nom de la vendeuse (entre guillemets) peut être remplacé par une adresse de cellule (sans guillemets) qui contient le nom

crdlmnt
0
Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022
1 710
Bonjour Vaucluse,
Comment Vas-tu ?

Tu n'aurez pas oubliez une parenthèse ? Tu fermes ton SommeProd après le =1 ( ou plutôt tu n'ouvres pas une parenthèse avant joursem() )

Cordialement.
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177 >
Messages postés
2755
Date d'inscription
jeudi 2 juillet 2015
Statut
Membre
Dernière intervention
10 janvier 2022

exacte double parenthèse derrière SOMMEPROD
.........pourtant la sieste est finie depuis un moment :-)
merci
bien cordialement
0
Messages postés
16546
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
12 janvier 2022
3 258
Bonjour

avec une formule colonne D donnant le jour de la semaine et un tableau croisé dynamique
http://www.cjoint.com/c/FDuoL3mH23t

edit:
excuse moi Vaucluse, je n'avais pas rafraichi ;o)

 Michel
0
Super mille merci à tous :)
0
Messages postés
26386
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 janvier 2022
6 177
pas de problème Michel, la saison n'est pas encore aux rafraîchissements!
Bien cordialement
0