Problème de configuration DNS serveur dédié pour Ubuntu [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016
-
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016
-
Bonjour,

Je sollicite votre aide car je n'arrive pas à relier mon nom de domaine avec mon serveur.

Je me suis acheté récemment un serveur dédié sur Kimsufi
Je me suis aussi procuré un nom de domaine sur 1&1

l'ip de mon serveur est la suivante : XXXXXXXXXX
le nom de domaine que je souhaite mettre en place est le suivant : killer-game.com

j'ai configuré mon serveur Kimsufi avec l'OS Ubuntu Server 14.04 "Trusty Tahr" LTS (64bits)

Je tente de relier mon nom de domaine avec mon serveur via bind9

voici la configuration de mon named.conf.local :

zone "killer-game.com" {
type master;
file "/etc/bind/zones/db.killer-game.com";
allow-transfer {XXXXXXXXXX;};
allow-query{any;};
notify yes;
};

zone "232.77.39.5.in-addr.arpa" {
type master;
file "/etc/bind/zones/232.77.39.5.in-addr.arpa";
};



Voici mes fichiers /etc/bind/zones/db.killer-game.com

$TTL 12H
$ORIGIN killer-game.com.
@ IN SOA ns.kimsufi.com. ownercheck.killer-game.com. (
2016041702 ; Serial
8H ; Refresh
30M ; Retry
4W ; Expire
8H ; Minimum TTL
)
IN NS ns324635.ip-5-39-77.eu.
IN NS ns.kimsufi.com.
killer-game.com. IN A XXXXXXXXXX
ns IN CNAME killer-game.com.
mail IN CNAME killer-game.com.
www IN CNAME killer-game.com.
ftp IN CNAME killer-game.com.
ownercheck IN TXT "xxxxxx"



ainsi que /etc/bind/zones/232.77.39.5.in-addr.arpa
$TTL 12H
@ IN SOA killer-game.com. postmaster.killer-game.com. (
2016041702 ; Serial
8H ; Refresh
30M ; Retry
4W ; Expire
8H ; Minimum TTL
)
IN NS ns.kimsufi.com.
IN PTR killer-game.com.


tout est OK quand je redémarre le service bind 9
et la commande
 named-checkconf /etc/bind/named.conf 

ne retourne aucune erreur

idem pour :
 
$ named-checkzone killer-game.com db.killer-game.com
zone killer-game.com/IN: loaded serial 2016041702
OK
$ named-checkzone killer-game.com XXXXXXXXXX.in-addr.arpa
zone killer-game.com/IN: loaded serial 2016041702
OK


Un nslookup me fait bien pointer vers mon serveur :

$ nslookup killer-game.com
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: killer-game.com
Address: XXXXXXXXX


Le problème vient quand j'essaie de faire pointer mon nslookup vers le serveur dédié en lui-même, j’obtiens l'erreur suivante :

$ nslookup killer-game.com ns.kimsufi.com
;; Got SERVFAIL reply from 2001:41d0:3:1c7::1, trying next server
Server: ns.kimsufi.com
Address: 213.186.33.199#53
                                          • server can't find killer-game.com: SERVFAIL


(je me suis inspiré du tuto https://www.idneo.fr/administration-serveur/configuration-bind9-et-parametrage-avec-ovh/ )

quelqu'un connaît-il l'origine de mon souci ? J'avoue y être depuis pas mal de temps et avoir beaucoup cherché sur Google mais sans succès.


Merci d'avance

2 réponses

Messages postés
35808
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 672
Salut,
quelqu'un connaît-il l'origine de mon souci ?
Il semblerait que ce soit toujours 1&1 qui gère le DNS ;-(

$ nslookup killer-game.com
Server: 127.0.1.1
Address: 127.0.1.1#53

Non-authoritative answer:
Name: killer-game.com
Address: 212.227.247.117


$ whois -H 212.227.247.117
[...]
inetnum: 212.227.247.0 - 212.227.248.255
netname: SCHLUND-CUSTOMERS
descr: 1&1 Internet
country: DE
org: ORG-SA12-RIPE


$ dig killer-game.com +nssearch
SOA ns-fr.1and1-dns.fr. hostmaster.1and1.com. 2016041301 28800 7200 604800 600 from server 217.160.81.4 in 31 ms.
SOA ns-fr.1and1-dns.fr. hostmaster.1and1.com. 2016041301 28800 7200 604800 600 from server 217.160.80.4 in 31 ms.
SOA ns-fr.1and1-dns.fr. hostmaster.1and1.com. 2016041301 28800 7200 604800 600 from server 217.160.82.4 in 31 ms.
SOA ns-fr.1and1-dns.fr. hostmaster.1and1.com. 2016041301 28800 7200 604800 600 from server 217.160.83.4 in 32 ms.
;; connection timed out; no servers could be reached

Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

Si je comprends bien, le problème ne vient plus de ma config Ubuntu mais de 1&1 ?
Si tel est le cas, ou dois-je effectuer les modifications sur 1&1 car j'avoue que leur interface me perd un peu...
Messages postés
35808
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 672 >
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

Je ne suis pas un spécialiste, mais je pencherai pour une redirection comme dans cette capture (Modifier la destination, ou Modifier les paramètres DNS) issue de cette page.
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

J'ai réussi à faire en sorte que mon nom de domaine pointe correctement vers mon ip mais aucun résultat.

$ nslookup killer-game.com
Server: 127.0.1.1
Address: 127.0.1.1#53

Non-authoritative answer:
Name: killer-game.com
Address: 5.39.77.232


Pourquoi n'ai-je toujours pas accès à mon url 5.39.77.232 quand je tape killer-game.com ?
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

(Je viens d'effectuer la modification et la commande

dig killer-game.com +nssearch

ne pointe plus sur rien du tout maintenant ....
Messages postés
35808
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 672 >
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

Je viens d'effectuer la modification
Quelle modification ?
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

Je suis allé sur 1&1

J'ai modifié les parametres DNS, et j'ai changé le bouton radio de

- serveurs de noms 1&1
à
-Autres serveurs de noms
puis j'ai ajouté ns-kimsufi.com.
Messages postés
35808
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
24 novembre 2020
5 672 >
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

Alors essaie de revenir comme avant, parce que là t'as tout cassé ;-(
Messages postés
15
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
17 avril 2016

J'ai remis comme avant, les modifications sont donc effectives et à jour, mais en revanche, je n'ai toujours rien :/