Formule SI avec des heures

[Résolu/Fermé]
Signaler
Messages postés
36
Date d'inscription
samedi 19 mars 2016
Statut
Membre
Dernière intervention
21 juin 2019
-
 Pijed -
Bonjour,

je cherche à faire une formule SI avec des Heures pour savoir si le téléphone sonne en dehors des heures d'ouverture de la société et si la société est ouverte si la standardiste répond.
Les horaires de la standardiste (KT) sont 09:15-13:00-13:45-17:45
Les horaires de la société sont : 8:00-17:45

J'ai un tableau sous cette forme

C2
Date Heure Destination Durée Sonnerie
01/04/2016 17:21:28 France 00:00:23 00:00:06

=SI(ET(C2>"09:15";C2<"13:00";C2>"13:45";C2<"17:45");"KT";SI(ET(C2<"08:00";C2>"17:45");"Fermeture";"Autre"))

Pour cette ligne la formule me sort "Autre" alors que ce devrait être "KT" puisque la sonnerie tombe dans les horaires de KT. J'ai l'impression qu'il y a un pb avec le >.

Quelqu'un a-t-il une idée?

Merci beaucoup

1 réponse

Messages postés
26220
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083
Bonjour
l'horaire ne peut pas être en même temps matin et après midi!

=SI(OU(ET(C2>"09:15";C2<"13:00");ET(C2>"13:45";C2<"17:45"));"KT";SI(OU(C2<"08:00";C2>"17:45");"Fermeture";"Autre"))

et par ailleurs, pour respecter les horaires mieux vaut peut être utiliser >= et <= dans une des deux SI pour inclure les limites


crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Merci beaucoup pour la réponse. Je n'ai pas encore essayé mais effectivement je pense que cela va beaucoup mieux marcher.

Bon WE
Bonjour,

en fait j'ai toujours un petit pb. Dans l'exemple ci-joint le résultat devrait être KT mais est "autre". J'ai du faire une petite erreur!! qui sait laquelle? Je vous remercie pour votre aide
C2
Date Heure Poste Numéro Destination Durée Sonnerie Achat HT SDA
01/04/2016 17:21:28 100 France 02 00:00:23 00:00:06 0 autre

=SI(OU(ET(C2>="09:15";C2<="13:00");ET(C2>="13:45";C2<="17:45"));"KT";SI(OU(ET(C2>="00:00";C2<"08:00");ET(C2>"17:45";C2<"24:00"));"Fermeture";"autre"))
Messages postés
26220
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 octobre 2021
6 083
on a du mal avec Excel à utiliser les horaires entre guillemets dans certaines formules (qui n'utilisent pas le ;comme séparateur entre adresse et condition)
essayez plutôt de placer les valeurs limites (toutes) dans un tableau hors champ et de remplacer dans la formule ces valeurs par les adresses des cellules qui les contiennent, ce sera plus sur


pour l'exemple problème rencontré en test chez moi
en A1: 24:00 en B1: 17:45 en C1 la formule =SI(ET(C1>B1;C1<A1);1;0) renvoie bien 1
alors que si j'écries
=SI(ET(C1<"24:00";C1>"17:45");1;0) la formule renvoie 0


Par ailleurs, la complication finale est inutile puisque le résultat à sortir est le même, de 17:45 à 8:00, soit "fermeture"
Autres ne sortira que si lC2 ne contient pas de valeur horaires ou se situe entre 13:00 et 13:45

crdlmnt
Effectivement cela fonctionne bien désormais.

Merci beaucoup pour votre aide.
Bonne soirée