Comptabiliser le nombre de cellules non vides dans une colonne [Résolu/Fermé]

Signaler
Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016
-
 al -
Bonjour,

je souhaite connaitre le nombre de cellules non vides dans une colonne et je bloque sur la formule à utiliser.

Merci de votre aide

6 réponses

Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
489
Bonjour,

Essaie avec :
=NB.SI(A:A;"<>")

A+
10
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016

merci pour la rapidité de la réponse mais désolée, ça ne marche pas ou alors je n'ai pas compris la formule,

j'ai remplacé a:a par le nom de ma colonne qui est j en l'occurrence et la réponse est erronée
Messages postés
701
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
9 octobre 2020
111
Bonsoir

=NBVAL(A1:A10)

Slts
Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016

Merci pour ta réponse rapide mais cela ne marche pas non plus.
Messages postés
12757
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
12 octobre 2020
2 040 >
Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016

Bonsoir sourceline

Si tu joignais un exemple de ton fichier, ça éviterait de faire des propositions dans le vide.
Fichier à poster sur cjoint.com, faire créer un lien, le copier et revenir le coller ici

Cdlmnt
Via
Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016

Ah, j'apprends encore un truc aujourd'hui ! merci, je vous mets donc un extrait de mon document

je voudrais que sur la colonne C44, on trouve le nombre de jour d'une des colonnes b ou c

https://www.cjoint.com/c/FDftXOenCwe

merci par avance
Messages postés
9578
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
12 octobre 2020
1 921
Bonjour à tous

Si le contenu "" de certaines cellules "vides" est obtenu avec une formule, tu peux essayer SOMMEPROD mais tu ne pourras pas l'appliquer à une colonne mais il te faudra préciser les bornes (tu peux tailler large sans problème)
Exemple
=SOMMEPROD((A1:A10000<>"")*1)

Cdlmnt
Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016

ok je vais essayer aussi cette formule
merci
Messages postés
3334
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
489
Tu devrais trouver le résultat avec les 3 méthodes :
https://www.cjoint.com/c/FDfvCdJtjMl

A+
Messages postés
23555
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
11 octobre 2020
6 400
Bonjour,

et une 4ème pour faire bonne mesure.
La plus simple : ne compte que les valeurs numériques :
=NB(C2:C40)

eric
Messages postés
10
Date d'inscription
mardi 13 octobre 2015
Statut
Membre
Dernière intervention
6 avril 2016

Je vous remercie tous d'avoir pris le temps de m'aider et en plus j'ai plusieurs solutions !!!!!

Bonne journée