Changer couleur cellule si valeur trouvée dans une ligne [Résolu/Fermé]

Signaler
-
 Fredy -
Bonjour,
Je suis débutant en excel et je n'arrive pas a trouver comment changer la couleur d'une cellule si la valeur de cette cellule se trouve dans une ligne donnée.

J’espère que j'ai été assez clair
Merci d'avance
Fredy

2 réponses

Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
Bonjour
mise en forme conditionnelle par formule
exemple à adapter: formater la cellule A1 quand A1:Z1 contient 1000
__ Sélectionner A1 (ou A1:Z1 pour formater toute la ligne)
__ Ruban /onglet accueil/ Icône / Mise en forme conditionnelle
__ Dans la liste affichée "nouvelle règle"
__ Dans la fenêtre suivante: "utiliser une formule..."
__entrer la formule:

=NB.SI($A1:$Z1;1000)>0

__ cliquer sur format / formater et OK OK

attention aux signes surtout les $devant les colonnes

si vous avez plusieurs lignes à traiter individuellement, sélectionnez le tout et entrez la formule correspondant à la 1° ligne, le reste s'ajuste



crdlmnt
__
Merci pour cette réponse rapide ;)
Ma question est un peu plus complexe.
A la place de 1000, j'ai une ligne de cellule.
Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
elle est tellement complexe qu'on ne la comprend plus
pouvez vous compléter?
ou mieux, déposer un modèle avec quelques explications sur:
https://www.cjoint.com/

_déposez le fichier _créez le lien (bas de page) _ copier le (haut de page)
et revenez le coller ici

crdlmnt
Voila le lien
http://www.cjoint.com/c/FCyohUPXCXx

Je veux juste changer la couleur de A3 si sa valeur est soit dans A12,B12, C12, D12, E12

Idem pour B3,C3...

cdt
Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020
5 506
alors voila si j'ai bien compris
.. en espèrant que ça convienne, sinon je vous laisse en d'autres mains, je suis parti jusqu'à dimanche soir
https://www.cjoint.com/c/FCyoCozEtdd
crdlmnt
>
Messages postés
25332
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 octobre 2020

Merci bcp, cela semble correspondre à ce que je cherchais.

cdt
Frédy