EXCEL - Identifier si contenu de n cases dans une matrice

[Résolu/Fermé]
Signaler
Messages postés
52
Date d'inscription
vendredi 12 octobre 2007
Statut
Membre
Dernière intervention
14 avril 2016
-
Messages postés
52
Date d'inscription
vendredi 12 octobre 2007
Statut
Membre
Dernière intervention
14 avril 2016
-
Bonjour,

J'ai un tableau disons allant de A1 à D8.
Pour chacune des cases j'ai un nom et prénom "Paul, Dupont".

A côté de ça j'ai une base de nom colonne M.
J'aimerai pouvoir créér une colonne m'indiquant pour chaque ligne si j'ai un des 4 noms de la ligne (A1, B1, C1, D1) est présent dans la base. Si c'est le cas, alors afficher "Ok" sinon "Ko".
C'est dans le but de faire un filtre.

Avez vous une idée ?
J'ai fait ceci mais ca ne marche que pour un seul nom de ma ligne...
=SI(ESTERREUR(RECHERCHEV(A1;$M$1:$M$18;1;FAUX));"Ok";"Ko")

Merci beaucoup
SerialFF

1 réponse

Messages postés
13095
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 septembre 2021
2 243
Bonsoir

Pourquoi n'essaye tu pas
=SI(NB.SI($M$1:$M$18;A1)+NB.SI($M$1:$M$18;B1)+NB.SI($M$1:$M$18;C1+NB.SI($M$1:$M$18;D1)>0;"OK";KO")

Cdlmnt
Via
Messages postés
26167
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 septembre 2021
6 036
Bonjour

peut être plus court avec:

=SI(SOMMEPROD(($M$1:$M$18;A1:D1))*1);"OK";"KO")

à tirer de 1 à 8

crdlmnt
Messages postés
52
Date d'inscription
vendredi 12 octobre 2007
Statut
Membre
Dernière intervention
14 avril 2016
3 >
Messages postés
26167
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 septembre 2021

Merci via55 et Vaucluse pour vos retours.
@via55 => Trop d'argurment dans la fonction
@Vaucluse => Affiche #Valeur pour chaque ligne


J'ai trouvé quelque chose un peu barbare, je pense que ca peut être simplifié mais ca marche :D
Merci d'avoir pris du temps pour mon probleme.
Je partage ma solution :

=SI(ESTERREUR(RECHERCHEV(A1;M:M;1;FAUX));(SI(ESTERREUR(RECHERCHEV(B1;M:M;1;FAUX));(SI(ESTERREUR(RECHERCHEV(C1;M:M;1;FAUX));(SI(ESTERREUR(RECHERCHEV(D1;M:M;1;FAUX));(SI(ESTERREUR(RECHERCHEV(E1;M:M;1;FAUX));"KO";"OK"));"OK"));"OK"));"OK"));"OK")
Messages postés
26167
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 septembre 2021
6 036 >
Messages postés
52
Date d'inscription
vendredi 12 octobre 2007
Statut
Membre
Dernière intervention
14 avril 2016

Je remet mon message je me suis trompé de fichier en pièce jointe
voila le test avec ma proposition qui ne devait pas être formulée correctement chez vous
https://www.cjoint.com/c/FCrqYK2daCI
ça fait quand même un peu plus court que votre proposition et ça permet d'allonger sans limite le champ des références.
crdlmnt
Ps: dans la proposition de Via assez simple pour votre besoin, il manquait juste une parenthèse derrière le C1
Messages postés
52
Date d'inscription
vendredi 12 octobre 2007
Statut
Membre
Dernière intervention
14 avril 2016
3 >
Messages postés
26167
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
10 septembre 2021

Merci beaucoup Vaucluse.
Ca marche très bien, synthétique et facilement adaptable !