Macro pour masquer des lignes de calendrier [Résolu/Fermé]

Signaler
Messages postés
50
Date d'inscription
dimanche 28 février 2016
Statut
Membre
Dernière intervention
9 août 2016
-
Messages postés
50
Date d'inscription
dimanche 28 février 2016
Statut
Membre
Dernière intervention
9 août 2016
-
Bonjour tous le monde,

J'ai créé un fichier pour planning avec un calendrier automate qui change en fonction du mois et de l'année, cependant au mois de février par exemple, il m'affiche le 28/02/2016 et 29/02/2016 en plus du 01/03/2016 et du 02/03/2016 sur cette même feuille.
Je souhaite mettre une macro qui me permettra de masquer ces lignes inutiles pour moi.

Je vous mets ci-dessous le lien de mon fichier pour mieux me comprendre.

https://www.cjoint.com/c/FCqj6EENY0l

Voilà, j'espère avoir été claire et merci d'avance pour vos réponses.

3 réponses

Messages postés
9496
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
7 juillet 2020
1 858
Bonjour

En A7
=SI(A6="";"";SI(A6+1>=DATE($A$1+2015;$B$1+1;1);"";A6+1))
à recopier vers le bas

RQ. Pourquoi ne pas utiliser simplement une liste de validation en A1 et B1(Données/Validation/Liste) à la place des liste déroulantes

Cdlmnt
Messages postés
50
Date d'inscription
dimanche 28 février 2016
Statut
Membre
Dernière intervention
9 août 2016

Bonjour,

Merci, c'est exactement ce que je voulais.
Euh pour la liste déroulante, ben j'ai choisit celle du formulaire parce qu'avec l'autre je n'arrive pas à avoir une cellule liée.

Cordialement,
Messages postés
16171
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
9 juillet 2020
2 989
Bonjour

pourquoi une macro ?

1/en A34
écrire
=SI(A33="";"";SI(MOIS(A33+1)>MOIS(A33);"";A33+1))
et tirer vers le bas jusqu'à A36
2:
faire une mise en forme conditionnelle sur ces 3 lignes : pas de fond ni de bordure

 Michel
Messages postés
50
Date d'inscription
dimanche 28 février 2016
Statut
Membre
Dernière intervention
9 août 2016

Bonjour,

Merci pour cette astuce, ca fait parfaitement l'affaire.
(Je pensais qu'on pouvait pas le faire sans macro)

Cordialement,
Messages postés
50
Date d'inscription
dimanche 28 février 2016
Statut
Membre
Dernière intervention
9 août 2016

Par contre j'ai pas réussi à faire la mise en forme conditionnelle.. J'ai mis nouvelle règle puis formule et j'ai écrit : =Si($A$6="";"") puis aucune bordure (j'ai essayé également bordure blanche) mais ca ne marche pas.

Vous avez une idée pourquoi ca ne marche pas? ma formule n'est pas bonne?

Merci.
Messages postés
9496
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
7 juillet 2020
1 858
Comme ceci
http://www.cjoint.com/c/FCqpk7ptomo

Cdlmnt
Messages postés
50
Date d'inscription
dimanche 28 février 2016
Statut
Membre
Dernière intervention
9 août 2016

Parfait ! merci beaucouup ^^