Mise en forme conditionnelle [Résolu/Fermé]

Signaler
Messages postés
8
Date d'inscription
lundi 14 mars 2016
Statut
Membre
Dernière intervention
6 avril 2016
-
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
-
Bonjour,
j'aimerai sur mon calendrier réalisé sur excel en PJ, mettre les week end et jours férié en couleur et si possible les jours antérieur à la date du jour

Merci pour votre aide

1 réponse

Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 493
Bonjour
Vous dites en PJ, mais elle est où , cette PJ?

en attendant:
faites hors champ, une liste des jours fériés à prendre en compte (nommons là jf pour l'exemple

sélectionnez le champ des dates MFC par formule (par exemple A2:X30 avec les dates en A)
(pour info: icône MFC / Nouvelle règle et "utiliser une formule")

Pour les WE (samedi et dimanche)
=JOURSEM($A2;2)>5
(bloquez le A avec $ si vous voulez formater la ligne de A à Z.. ou la colonne si votre tableau à les dates en ligne, oupas du tout si vous ne voulez que la cellule)

pour les jours fériés:
=NB.SI(jf;$A2)>0

pour les deux au même format:
=OU(JOURSEM($A2;2)>5;NB.SI(jf;$A2)>0)

pour les jours "passés"
=$A2<AUJOURDHUI() ou encore s'il y a des cellules vides à ne pas considérer:
=ET($A2>0;$A2<AUJURDHUI())

et éventuellement pour le jour en cours:
=$A2=AUJOURDHUI()

utilisez les flèches ascenseur de la fenêtre d MFC pour placer les formules dans le bon ordre (selon que vous voulez <AUJOURDHUI avant ou après les WE et jf., la première condition trouvée élimine les autres)

si ça ne va pas, déposez, le fichier sur:
https://www.cjoint.com/
et revenez coller ici le lie créé sur le site
crdlmnt


La qualité de la réponse dépend surtout de la clarté de la question, merci!
Messages postés
8
Date d'inscription
lundi 14 mars 2016
Statut
Membre
Dernière intervention
6 avril 2016

Merci pour votre retour,
ci-dessous le lien de la pièce jointe

https://www.cjoint.com/c/FCokYtzffPM

Merci d'avance
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 493
Voila ce que je peux vous proposer
j'ai recréer les feuilles en fonction de la mise en place du datage automatique et des MFC
voyez sur la feuille Data, les explications

https://www.cjoint.com/c/FCol7dgpWhm

pour voir les MFC, sélectionnez une cellule du tableau / Onglet accueil / Icône mise en forme conditionnelle et
"gérer les règles"

revenez si besoin

crdlmnt
Messages postés
8
Date d'inscription
lundi 14 mars 2016
Statut
Membre
Dernière intervention
6 avril 2016
>
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020

Merci beaucoup c'est exactement ce que je cherchais !
cordialement
Messages postés
25318
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 septembre 2020
5 493
Pas de quoi, je passe le sujet en résolu
Bonne route
crdlmnt