Sommer en fonction du mois sélectionnée [Résolu/Fermé]

Signaler
-
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
-
Bonjour,

J'ai un soucis que je sais pouvoir régler avec des successions de fonctions et de tableau. Je ne sais pas lesquelles et je pense qu'il doit y avoir plus simple que ce à quoi je penserais.

Je dois faire un TBS et j'aimerais comparer en présentation la même période sur plusieurs années. J'ai une feuille de données, dans laquelle je rentre tout mensuellement.

Mon soucis est que mon tableau de feuille prez somme, par exemple, les données de Janvier à Juillet si je sélectionne Juillet comme étant le mois en cours (liste déroulante). Et ne pas avoir à changer les formules tous les mois...

Merci de votre aide (je n'ai jamais eu de formation poussée sous Excel donc soyez indulgents ;)

1 réponse

Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
Bonjour

dans cell1 > le N° du mois cherché à la place du nom de mois
dans cell2 > le N° de l'année si vous devez aussi cumuler avec l'année:


=SOMMEPROD((MOIS(Champ date)=Cell1)*(ANNEE(champ date)=Cell2)*(champ à sommer))

limitez les champs avec des N° de colonne et de ligne pour que le fichier soit moins lourd: genre: A1:A100 et pas A:A
le champ à sommer ne doit pas coporter de texte

si vous n'avez pas besoin de l'année, supprimer l'item correspondant dans la formule :

=SOMMEPROD((MOIS(Champ date)=Cell1)*(champ à sommer))

crdlmnt


Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
C'est effectivement un peu différent de ce j'avais imaginé
voyez ici:
https://www.cjoint.com/c/FCdi27iwvMv
j'ai aussi fait quelques petites modifs:
le menu déroulant de b1 se réfère à C3:N3 (meilleurs moyen de ne pas avoir de différence d'écriture entre les titres et la valeur cherchée, ce qui était le cas pour sept, oct dec)
le titre de colonne du résultat affiche le mois choisi
revenez si besoin
crdlmnt
Top !! Merci beaucoup !!
Pourriez-vous m'expliquer rapidement ? La fonction décaler, les ; successifs et la fonction equiv ?
Si non, je comprendrai en cherchant
Merci encore !
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
principe de la formule:

DECALER(cell départ; valeur décalage ligne; valeur décalage colonne)
renvoie la valeur de la cellule situé à valeur ligne et colonne à partir de la cellule départ indiquée

DECALER(cell départ;valeur;décalage ligne;valeur de décalage colonne;hauteur de champ; largeur de champ)
définit une plage décalée à partir de la cellule départ, du nombre de lignes indiquées dans "hauteur" et du nombre de colonne dans largeur

EQUIV(valeur;champ;0)
définit le rang dans le champ de la valeur indiqué en début de formule
le 0 indique à Excel qu'il ne faut considérer que des valeurs exactes

donc la formule de votre tableau en O4
=SOMME(DECALER($C4;;;;EQUIV($B$1;$C$3:$N$3;0)))

fait la somme du champ:
__à partir de la cellule C4
__sans décalage de ligne ou de colonne et sans hauteur de champ, puisque il faut imaginer que pour Excel par défaut les points virgules successifs valent 0
__et en final, de la largeur définit par le code EQUIV, qui ressort le N° de position du mois dans le champ C3:N3

espérant avoir été assez clair, ce n'est pas toujours facile par écrit

crdlmnt
C'est vraiment génial et l'explication est plus claire que celle d'Excel... les descriptions de fonctions seraient vraiment à revoir
Mais comment parvenez-vous à faire des trucs pareils ???
Messages postés
25625
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
28 novembre 2020
5 627
"Mais comment parvenez-vous à faire des trucs pareils"

Bof...sais pas..!!!!

je passe le sujet en résolu
Bonne route
crdlmnt