Double condition en cascade [Résolu/Fermé]

Signaler
Messages postés
51
Date d'inscription
mardi 10 février 2015
Statut
Membre
Dernière intervention
20 mai 2017
-
Messages postés
51
Date d'inscription
mardi 10 février 2015
Statut
Membre
Dernière intervention
20 mai 2017
-
Bonjour,

Je cherche la formule pour une validation de données de sorte que dans le menu déroulant attaché à ma cellule, s'affiche les données des cellules de la feuille parente «catégories» colonne C; si une cellule C est vide, il faut que s'affiche le contenu de la cellule B de la même ligne (et de la même feuille); enfin, si B est vide, il faut que s'affiche le contenu de la cellule A de la même ligne.

Merci d'avance,


1 réponse

Messages postés
13064
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 juillet 2021
2 221
Bonjour kambro

Le plus simple établir une liste complète dans la feuille catégories dans une 4eme colonne
Par exemple en D1 mettre la formule :
=SI(B1<>"";B1;SI(C1<>"";C1;A1)) et l'étirer au bas des colonnes
Selectionner cette plage de valeur en D et la nommer (clic droit Nommer plage) ma_liste
Utiliser ce nom dans la source de la validation de données de la liste déroulante de l'autre feuille

Cdlmnt
Via
Messages postés
51
Date d'inscription
mardi 10 février 2015
Statut
Membre
Dernière intervention
20 mai 2017
7
Merci mille fois: ça marche parfaitement. Je suis bien dépanné.

Recevez mes salutations,

Kambro