Calculer nombre de ligne sur un tableau déjà trié [Résolu/Fermé]

Signaler
Messages postés
10
Date d'inscription
mardi 19 février 2013
Statut
Membre
Dernière intervention
24 décembre 2015
-
Messages postés
52626
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
-
bonjour,

j'ai eu beau faire des recherches sur toutes sortes de forum, je n'arrive pas à trouver la formule qui me permettrait de simplement calculer le nombre de ligne sur un tableau déjà filtré. faut dire que je ne suis pas une pointure sur excel.

je m'explique, j'ai un tableau avec x lignes, je veux en exclure un certain nombre (que je surligne en jaune par ex). comment dénombrer la totalité lignes surlignées en jaune rapidement ?

je ne sais pas si c'est très clair, mon fichier se trouve ci-dessous !

http://www.cjoint.com/c/ELyonJTtcHm

merci bcp pour les bonnes âmes qui prendront le tps de me répondre en cette période festive !

8 réponses

Messages postés
52626
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
14 536
Bonjour.

C'est très simple : il ne faut pas essayer de travailler avec des couleurs entrées manuellement, car ta fonction NbCoul n'est qu'une aimable fantaisie, mais travailler sur la colonne AV, où tu décompteras le nombre de cellules renseignées ...

C'est bien, la retraite ! Surtout aux Antilles ... :-) 
Raymond (INSA, AFPA, CF/R)
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 336
Bonjour,

pour compter les couleurs appliquées manuellement il est préférable de passer par un code VBA si tu connais, si non il est possible de compter ces couleurs en utilisant une colonne supplémentaire qui pourra être masquée.
A toi de préciser ton choix pour éviter de travailler inutilement ce soir
ok, je m'y jette tout de suite ! merci Mike !
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 336
Re,

c'est toute la suite que le demandeur donne à sa demande ???

oh pardon, pardon !!! je n'ai vraiment pas pu répondre avant aujourd'hui !!! j'en suis vraiment désolée !!!

pour Raymond , j'ai bien compris qu'il fallait décompter le nb de cellules couleur, mais comment le faire ?

Pour Mike, je ne suis vraiment pas une pointure sur excel, VBA, je sais juste ce que veulent dire les initiales, c'est dire ...
donc, oui, une colonne masquée avec formule magique me conviendrait parfaitement !

merci bcp !!
Messages postés
52626
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
13 novembre 2020
14 536
NON !
NON !
NON !

Pas "décompter le nombre de cellules couleur" mais
"tu décompteras le nombre de cellules renseignées", donc vides ou pas vides !
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 336
Re,

Alors en fonction du fichier fourni, exemple active la cellule BA2 et Gestionnaire de noms
nommer le champ exemple ComptCoul et saisie cette formule
=LIRE.CELLULE(38;DTE5674_H_P_O_181200272291935!Y2) 

fermer l'assistant
alors que ta cellule BA2 est encore active dans la barre des formules saisir cette formule
=ComptCoul

incrémente cette formule vers le bas, cette colonne BA pourra être masquée

dans la cellule de ton choix colle cette formule
=NB.SI(BA2:BA258;6)

si la couleur utilisée colonne Y est différente tu peux également écrire =NB.SI(BA2:BA258;"<>0")

pour utiliser la fonction LIRE.CELLULE il va falloir accélérer le recalcul, pour cela il va falloir écrire une ligne de code en BVA
clic droit sur l'onglet de ta feuille/Visualiser le code, colle ce code
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
Application.CalculateFull
End Sub

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
je suis désolée, mais lorsque je saisi la formule en BA2 , il m'est indiqué 'fonction non valide), je ne sais pas ce que j'ai fait de travers ...
pardon, je n'étais pas passé par l'assistant ! c'est tout bon à présent !!!

merci bcp Mike ! C'est vraiment gentil d'avoir pris le tps de se pencher sur mon pb ! !!!
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 336
Re,

parce que tu rentres certainement la formule dans la cellule, je t'ai dit de sélectionner BA2 et d'ouvrir le gestionnaire de nom/Nouveau/donner un nom, dans le fichier joint j'ai nommé ComptJaune et saisir cette formule
=LIRE.CELLULE(38;DTE5674_H_P_O_181200272291935!Y2)
ensuite dans la barre des formules saisir =le nom de champ nommé dans le fichier joint =ComptJaune
et incrémenter vers le bas
ensuite une simple formule =NB.SI que j'ai mis en AY2
en AY4 j'ai ajouté un NB.SI pour compter les cellules non colorisées
et une ligne de code VBA dans le visual pour accélérer le recalcul
https://www.cjoint.com/c/ELBjeFzIy4j
Oui, c'est génial! Merci merci! Mais je me suis contentée de recopier tes instructions à la lettre, je n'y comprends toujours rien. .....tant pis, mon pb est résolu à présent! Bonne journée!
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 336
Re,

LIRE.CELLULE(no_type; référence)
no_type est la syntaxe pour identifier la couleur de fond de la cellule et donc renvoi l'index couleur soit pour le jaune 6, si tes cellules était en rouge la syntaxe renverrait l'index 3 etc...
la référence
est l'identification de la cellule, dans ton cas la première cellule fichier DTE5674_H_P_O_181200272291935! et cellule Y2

ensuite NB.SI compte le nombre de valeur égale à l'index 6

et la ligne VBA Application.CalculateFull permet de forcer le calcul dès que la cellule active change de position

Comme tes attentes semblent satisfaites, je passe le statut de la discussion en résolu

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.