[Ubuntu] De l'aide pour débutant... [Résolu/Fermé]

Signaler
Messages postés
86
Date d'inscription
vendredi 3 novembre 2006
Statut
Membre
Dernière intervention
24 juillet 2010
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

J'ai décidé de mettre UBUNTU sur mon 2ème ordinateur et je rencontre quelques soucis dans ma quête d'apprentissage sur le tas :)

Pour certain ça semblera facile, mais pour moi c'est un nouvel univers... on est loin de Windows et son B.A.BA.

Voici mes problèmes :

1) Comment installer les plugins utilisés pour les animations des sîtes web ?
2) Comment rajouter un logiciel téléchargé par le biais d'Ajouter/Enlever et qui ne se met pas automatiquement dans la liste "Applications", "Raccourcis" ou "Système", alors qu'il est annoncé comme installé ?
3) Comment installer un logiciel téléchargé ou chargé à partir d'un CD qui est soit-disant compatible LINUX et qui ne s'installe pas ?
4) Où sont stocké les fichiers téléchargé par le biais de "Ajouter/Enlever" ?

Voilà rien que ça... si quelqu'un peut m'aider ou m'apporter une formation ça serait pas de refus... J'ai pas trouvé le forum d'ubuntu-fr.org très clair... Où alors j'ai pas encore les compétences... alors merci aux bonnes âmes ;)

46 réponses

Messages postés
1791
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
15 août 2020
560
Pour moi le problème n'est pas réglé du tout :D

Sinon essayes ceci (je sais pas si c'est les bons paquets que je te recommande mais bon, je les ai d'installés lol):
sudo apt-get update
sudo apt-get install libalut0 


Sinon pour firefox:
sudo apt-get remove firefox

ou
sudo apt-get autoremove firefox
(à confirmer!)
puis
sudo apt-get install firefox


Pour le flash-plugin il depends de ceci:
- libc6
- libfontconfig1
- libfreetype6
- libglib2.0-0
- libgtk2.0-0
- libx11-6
- libxext6
- libxt6
Essayes donc de les installer/reinstaller
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
Pour moi le problème n'est pas réglé du tout

J'entend bien mais j'y crois plus au "miracle" ! -DDDDD
Je suis le premier a être frustré de ne pas avoir la solution mais vraiment je crois qu'il y a des choses hautement plus intéressantes que le plugin de flashplayer -DDD

Si avec gnash ça a fonctionné je pense que cela restreint fortement le nombre de possiblités !
je vais regarder voir pour les librairies que tu m'indiques !
Je ne suis pas spécialiste en plugins, ni en librairies mais bon j'essaie de raisonner -DDDD


:-)
Messages postés
1791
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
15 août 2020
560
Celui qui ne tente rien n'as rien :D
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
Re-,

ben j'ai fait :

- libalut0 (je l'avais pas !) mais rien donné !
- réinstallation de firefox mais rien donné !
- les librairies indiquées : je les avais déjà !

bilan "rien donné" ! -DDDD


je viens à l'instant de refaire une réinstallation d'Ubuntu ....juste pour m'amuser et voir !

:-))
Messages postés
1791
Date d'inscription
mardi 24 juillet 2007
Statut
Membre
Dernière intervention
15 août 2020
560
sudo apt-get autoremove
sudo apt-get update
sudo apt-get upgrade
sudo apt-get remove firefox
sudo apt-get remove flash-plugin
sudo apt-get update
sudo apt-get install firefox
sudo apt-get install flash-plugin
sudo apt-get install flashplugin-nonfree


essaye aussi "aptitude"
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
RESOLU !

Le "miracle" s'est finalement accompli ! Pas sous Ubuntu mais sous Debian ! J'ai du son via firefox (flashplayer).
Là encore je ne saurai expliquer pourquoi si ce n'est donner quelques informations :

- vieille carte son

- ESD désactivé.
- OSS
- et quelques pasuetages : streamtuner, xmms, mozilla-player, libflash-mozplugin (totem-mozilla, sun-java6-plugin ...puisque j'y suis!).

et voilà je peux entendre le son (flashplayer) via firefox, écouter la radio (xmms), .....


Notes : il est bien entendu que cela n'est pas un problème lié à Ubuntu. Je n'ai pas la moindre idée du "pourquoi" mais cela fonctione !


Et encore une fois un grand merci à lami20j pour son "coup de main".

bonne journée.


:-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466 >
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014

Correctif :

- ESD désactivé.
- OSS activé.
- et quelques paquetages : streamtuner, xmms, mozilla-player, libflash-mozplugin, w32codecs
(+ totem-mozilla, sun-java6-plugin ...dans la foulée).

:-))
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466 >
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014

Bonjour,

Aujourd'hui en rallumant la machine, j'avais perdu à nouveau le son sous firefox !
J'ai définitivement réglé le problème en créant un fichier /home/user/.asoundrc

redfox@debian:~$ cat .asoundrc
pcm.via82xx {
    type hw
    card 0
}
ctl.via82xx {
    type hw
    card 0
}

pcm.!default {
    type plug
    slave.pcm "asymed"
}

pcm.asymed {
   type asym
   playback.pcm "dmixer"
}


redfox@debian:~$

voilà je retrouve à nouveau le son sous firefox et à chaque démarrage.


Notes : encore quelques imperfections :

message d'erreur dans la console :

ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM dmixer


et ceci également (dès que je fait un vi sur le fichier .asoudrc semble-t-il)

Information artsmessage

Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (Device or resource busy)
The sound server will continue, using the null output device.



Malgré ces deux messages cela fonctionne très bien !


:-))
Messages postés
86
Date d'inscription
vendredi 3 novembre 2006
Statut
Membre
Dernière intervention
24 juillet 2010
7
Pour moi tout est OK... je vous laisse continuer la discussion ;)

Je récapitule les solutions à mes questions :

1) Comment installer les plugins utilisés pour les animations des sîtes web ?

Ouvrez un terminal (Menu Applications > Accessoires > Terminal) et tapez:
sudo aptitude install -y flashplayer-nonfree
(Entrez votre mot de passe (password) s'il vous est demandé. Répondez "oui" si une question vous est posée.)

2) Comment rajouter un logiciel téléchargé par le biais d'Ajouter/Enlever et qui ne se met pas automatiquement dans la liste "Applications", "Raccourcis" ou "Système", alors qu'il est annoncé comme installé ?

clic-droit sur le menu, et on peut le modifier.

3) Comment installer un logiciel téléchargé ou chargé à partir d'un CD qui est soit-disant compatible LINUX et qui ne s'installe pas ?

En général, il faut éviter d'installer des logiciels hors des dépôts Ubuntu.
Lance Synaptic: tu verra qu'il y a bien plus de logiciel proposé que le menu "Ajouter/enlever".
Si le logiciel que tu veux installer se termine en .exe ou .msi, alors c'est un logiciels Windows qui ne marchera pas sous Linux.

4) Où sont stocké les fichiers téléchargé par le biais de "Ajouter/Enlever" ?

Une fois installé, c'est réparti dans divers répertoires:
/etc/ pour les fichiers de configuration
/usr/bin pour les programmes eux-même (lanceurs)
/usr/share/ pour les fichiers utilisés par ces programmes
/var/log pour les logs d'exécution des programmes (comptes-rendu d'exécution)
etc.
Voir:
linarb

Voilà, merci à tous pour votre aide... A bientôt...