Ne pas prendre en compte si

[Résolu/Fermé]
Signaler
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
-
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
-
Bonjour,

Je voudrais savoir si il existe une formule afin de ne pas prendre en compte une cellule si dans celle-ci il y a écrit "KO".
J'ai trouvé cette formule =NB.SI(G37:R37,">KO<")/9 mais avec celle-ci le resultat marche un coup sur 5 et je ne sais pas pourquoi.
Est-ce que quelqu'un aurait une idée ?

Cordialement,
Florian

4 réponses

Messages postés
1036
Date d'inscription
mardi 2 février 2010
Statut
Membre
Dernière intervention
5 janvier 2017
139
Salut,
Normalement avec ce principe ça devrait fonctionner :
si "KO" alors fais rien sinon fais ce que je veux.
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
95
Bonjour,

Je sais, sur le principe cela devrait marcher mais bizarrement cela marche un coup sur 5 en fonction de ce que l'on écrit j'ai l'impression
Messages postés
16497
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 août 2021
3 210
bonjour
=NB.SI(G37:R37;"<>KO")
renvoie le nombre de cellule différente de KO
Messages postés
1036
Date d'inscription
mardi 2 février 2010
Statut
Membre
Dernière intervention
5 janvier 2017
139
Je pense que le /9 n'as rien à voir dans les erreurs.
Messages postés
16497
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 août 2021
3 210
reste à savoir si tu es sur un Excel Francophone sinon il faut dire au départ de ta demande quel est la langue de l'Excel utilisé
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
95
je suis bel et bien sur un excel francophone...
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
844
Bonjour,

Ce sont tes options régionales windows qu'il faut vérifier.
En option us avec un Excel français et tu devras utiliser la virgule à la place du point -virgule.

Cordialement
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
95
Si au final il faut juste remplacer les points virgules par des virgules, pas la peine de toucher au option regionales pour cela, c'est pas la fin du monde :D
Messages postés
16497
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 août 2021
3 210
Mettre le classeur sans données confidentielles en pièce jointe sur https://www.cjoint.com/
et coller le raccourci proposé (clic droit) dans le message de réponse

Dans l’attente

Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
95
http://www.cjoint.com/c/ELrky1VHEKS
En espérant trouver une solution
Messages postés
16497
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
28 août 2021
3 210 >
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017

=(NB.SI(D7:L7;"<>KO")-NB.SI(D7:L7;""))/5

Il aurait été + sage d' élargir les colonnes catégories que de mettre plusieurs colonnes qui + est fusionnée
avec des cellules fusionnées sur plusieurs colonnes, XL compte le nombre de cellules-->
1 données= 1 occupée et 3 Vides si 4 colonnes fusionnées
Messages postés
2563
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
31 août 2021
1 169
Bonjour
Tester
=NB.SI(D7:L7;"<>KO")/5
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
95
formule deja donnée par michel_m un peu plus haut
Cette formule me donne un résultat de 180%
Effectivement les KO ne sont pas pris en compte mais le résultat est de base (sans valeur dans les cellules) de 180%, en revanche il baisse si on met un KO
Messages postés
2563
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
31 août 2021
1 169
tester
=NB.SI(D7:L7;"<>KO")/NB.SI(D7:L7;"<>""")
les cellules fusionnées perturbent peut être le calcul ?
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
844
c'est normal, tes cellules sont fusionnées.
utilises plutôt =SOMMEPROD((D7:L7<>"")*(D7:L7<>"KO"))/5
Messages postés
650
Date d'inscription
jeudi 13 novembre 2014
Statut
Membre
Dernière intervention
28 novembre 2017
95
c'est parfait JvDo
Merci à tous pour votre aide

Cordialement,
Florian