Interdire le copier/coller [Résolu/Fermé]

Signaler
Messages postés
782
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
3 juin 2021
-
Messages postés
782
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
3 juin 2021
-
Bonjour à tous et à tous les pros de la vba,

Serait-il possible d'interdire le copier/coller de cellules entre elles, un exemple pour ne pas en citer d'autres onglet janvier interdiction de copier d12 puis coller en d40, par contre autoriser le copier/coller de la plage complète exemple onglet janvier copier la plage D13:D62 et la coller onglet février D13:62 ou vice-versa

En somme il faudrait interdire le copier/coller de cellule par cellule, mais autoriser le copier/coller de plages complètes


http://www.cjoint.com/c/ELoszge0lNs

Cordialement

3 réponses

Messages postés
782
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
3 juin 2021
138
Re

Je joins le fichier original, mais en version super allègé pour mieux comprendre le problème.
Si je sélectionne D12 je fais un clic droit pour copier la sélection et que je la colle en D16 j'aurai déjà le trait noir en gras de la mise en forme qui apparaitra, (déjà premier truc qui fou la pagaille)

Ensuite deuxième chose si je selectionne D12 je vais dans les Données puis validation il y aura cette formule dedans =SI(D12<>"";DECALER(DEBUT_POSTES;EQUIV($D$12&"*";POSTES;0)-1;;SOMME((STXT(POSTES;1;NBCAR(D12))=TEXTE(D12;"0"))*1));POSTES)

Si je colle la selection D12 sur D16 une petite partie de la formule ne suivra pas en couleur noir gras =SI(D16<>"";DECALER(DEBUT_POSTES;EQUIV($D$12&"*";POSTES;0)-1;;SOMME((STXT(POSTES;1;NBCAR(D16))=TEXTE(D16;"0"))*1));POSTES) deuxieme chose qui fou la pagaille

Voilà pourquoi mon intérêt de pouvoir copier une plage, mais pas une cellule


http://www.cjoint.com/c/ELponzOq4gs
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
8536
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 mai 2021
1 669
Pourquoi ??? Dans quel but ???
Messages postés
782
Date d'inscription
dimanche 15 novembre 2015
Statut
Membre
Dernière intervention
3 juin 2021
138
Bonjour Patrice33740

En fait le fichier que j'avais joint n'était qu'un exemple, l'original c'est un calendrier qui comporte 12 onglets (les douze mois de l'année) et des données modifiables par liste déroulante en D12:D62 pour les postes de travail et E12:E62 pour les noms des personnes. Alors si je ne veux pas qu'on puisse copier de cellule en cellule c'est pour ne pas foutre la pagaille dans les données de validation que comporte chaque liste dans les cellules, par contre en copiant la plage complète de donnée le risque est éliminé au cas où l'on voudrait reporter d'un mois au mois suivant les mêmes données. En espérant être assez clair dans mon explication.

Cordialement
Messages postés
8536
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 mai 2021
1 669
Il n'y a aucune raison pour que le copier / coller sème la pagaille dans la validation de cellule !!!
Messages postés
8536
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
8 mai 2021
1 669
PS : pour définir le nom de la plage nommée « Postes » il est préférable de remplacer la plage fixe :
=Saisie!$A$2:$A$62
par une plage dynamique qui ne propose que les valeurs existantes :
=DECALER(Saisie!$A$1;1;0;NBVAL(Saisie!A:A)-1)
et faire de même pour les « Noms »