Somme d'une colonne dans l'en-tête [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
mardi 24 novembre 2015
Statut
Membre
Dernière intervention
24 novembre 2015
-
Messages postés
3
Date d'inscription
mardi 24 novembre 2015
Statut
Membre
Dernière intervention
24 novembre 2015
-
Bonjour,

Je suis sous Excel 2013.

Depuis un moment, j'aimerais trouver une formule élégante pour additionner les valeurs d'une colonne entière. Je veux pouvoir modifier à loisir ma liste, et surtout figer la première ligne avec mes totaux en en-tête.

La formule de base est =SOMME(A:A), mais comme je mets la somme en-tête (case A1), excel m'annonce poliment que je suis un idiot de faire une référence circulaire.

Donc, on peut faire quelque chose du genre =SOMME(A2:A1000), mais si je supprime 3 lignes la formule se transforme en =SOMME(A2:A997), ce qui est légèrement embêtant quand par la suite je rajoute des valeur à ma liste.

Du coup, après quelques recherches dans le forum je peux bricoler quelque chose avec la formule DECALER(). C'est bien, ça marche super, mais mon nombre d'entrées est toujours limité à la valeur que je mets dans l'argument [hauteur].

Par exemple en A1 :
=SOMME(DECALER($A$1;1;;10000;))&" € HT "

Y a-t-il un quelconque moyen, sans passer par les macros, de faire tout simplement "la somme de la colonne entière sauf la première ligne, quelles que soient les modifications apportées à la-dite colonne" ?

Merci d'avance !

A plus,
A10H4
A voir également:

3 réponses

Messages postés
17300
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 janvier 2021
4 431
Re,

en fait la formule est =SOMME(A2:A"dernière cellule de la colonne")
il faut donc écrire une formule pour avoir l'adresse de la dernière cellule qui est
ADRESSE(EQUIV(MAX(A:A);A:A);1;1)
il suffit d'encadrer le résultat de la syntaxe INDIRECT()
ce qui donne au final
=SOMME(A2:INDIRECT(formule d'identification dernière cellule))

il est également possible d'utiliser d'autre formulation comme =SOMME(INDIRECT("A2:A"& identification index ligne))
exemple
=SOMME(INDIRECT("A2:A"&(MAX(EQUIV(9^9;A:A)))))

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
3
Date d'inscription
mardi 24 novembre 2015
Statut
Membre
Dernière intervention
24 novembre 2015

Ha merci beaucoup !

C'est finalement =SOMME(INDIRECT("A2:A"&(MAX(EQUIV(9^9;A:A))))) qui marche !
Les autres me donnent toujours une référence circulaire.

Bonne fin de journée !
A10H4
Messages postés
17300
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
13 janvier 2021
4 431
Bonjour,

essaye comme cela voir

=SOMME(A2:INDIRECT(ADRESSE(MAX(EQUIV(9^9;A:A);EQUIV("z";A:A));1)))

ou encore
=SOMME(A2:INDIRECT(ADRESSE(EQUIV(RECHERCHE("zz";A:A);A:A);1;4)))

encore plus court
=SOMME(A2:INDIRECT(ADRESSE(EQUIV(MAX(A:A);A:A);1;1)))
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
3
Date d'inscription
mardi 24 novembre 2015
Statut
Membre
Dernière intervention
24 novembre 2015

Merci, je vais étudier ça.
Débutant en excel, j'apprends au fil des essais :-P
Là pour le moment j'ai compris =SOMME(A2:((((;A:A);(;A:A));)))

A plus :-D
A10H4
Messages postés
1941
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
23 août 2020
141
Bonjour,

En général, on fait le total en fin de tableau, et celui-ci s'adapte aux insertions/suppressions de lignes/cellules.
Tu peux le recopier en A1 (ex : =A16)

A+