Retirer les cellules vides d'une colonnes (formule ?) [Résolu/Fermé]

Signaler
Messages postés
3
Date d'inscription
vendredi 6 novembre 2015
Statut
Membre
Dernière intervention
7 novembre 2015
-
Messages postés
850
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
15 février 2019
-
Bonjour,
J'ai une colonne de données C3:C11 comprenant des cellules vides:
text1
text2
text3
""
text5
text6
""
text8
text9

Je voudrais que cette colonne soit dans une autre colonne E3:E11 a coté mais sans les cellules vide:
text1
text2
text3
text5
text6
text8
text9
#NOMBRE!
#NOMBRE!

j'ai utilisé cette formule dans E3:
=INDEX(C3:C11;PETITE.VALEUR(SI(C3:C11<>"";LIGNE(INDIRECT("1:"&LIGNES(C3:C11))));LIGNES($1:1)))

(ctrl+shift+entrée)

le résultat est le suivant
text1
text3
text6
text9
#NOMBRE!
#NOMBRE!
#NOMBRE!
#NOMBRE!
#NOMBRE!

mon problème : pourquoi cette formule ignore la cellule text2, text5 et text8
aidez moi svp

Merci d'avance

2 réponses

Messages postés
3
Date d'inscription
vendredi 6 novembre 2015
Statut
Membre
Dernière intervention
7 novembre 2015
1
Bonjour tout le monde,

j'ai trouvé la solution pour cette formule :

=INDEX(C$3:C$11;PETITE.VALEUR(SI(C$3:C$11<>"";LIGNE(INDIRECT("1:"&LIGNES(C$3:C$11))));LIGNES($1:1)))

remarque : et pour éviter le message d'erreur #NOMBRE!

=SIERREUR(INDEX(C$3:C$11;PETITE.VALEUR(SI(C$3:C$11<>"";LIGNE(INDIRECT("1:"&LIGNES(C$3:C$11))));LIGNES($1:1)));"")

(ctrl+shift+entrée)


Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 56912 internautes nous ont dit merci ce mois-ci

Messages postés
850
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
15 février 2019
38
Bonjour,

Je propose de vous répondre en VBA puisqu'il n'y a pas encore de réponse.

Code :

Sub Code()

Dim DL As Long

DL = Cells(Application.Rows.Count, 3).End(xlUp).Row

x = 3

For i = 3 To DL

If Range("C" & i) <> "" Then
    Range("C" & i).Copy Range("E" & x)
    x = x + 1
End If

Next i

End Sub


Le fichier test : https://www.cjoint.com/c/EKgn26m6vPf

Cordialement.
Messages postés
3
Date d'inscription
vendredi 6 novembre 2015
Statut
Membre
Dernière intervention
7 novembre 2015
1
Merci pour cette solution Kuartz mais j'ai trouvé ou réside le problème dans cette formule il fallait juste ajouter $ pour fixer les lignes de ma la colonne C :

=INDEX(C$3:C$11;PETITE.VALEUR(SI(C$3:C$11<>"";LIGNE(INDIRECT("1:"&LIGNES(C$3:C$11))));LIGNES($1:1)))

et ça marche très bien.

Salutations
Messages postés
850
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
15 février 2019
38
Parfait dans ce cas :) Bonne continuation !