EXCEL SOMME.SI avec validation en fonction d'une colonne [Résolu/Fermé]

Signaler
-
 Benny -
Bonjour,

Je cherche une formule sous Excel pour faire mes tableau récapitulatif.

J'ai un tableau la liste des contrats (Client) avec en colonne A la date des contrats.
En colonne B le Chiffre d'affaire.
En colonne C l'état du contrat (En attente / Validé / Annulé)

Je voudrais utiliser la formule suivante :
=SOMME.SI(Client;"24/10/2015";CLIENTS!B:B)

Je voudrais que la formule fasse le total du Chiffre d'affaire par jour mais en prennant en compte la colonne C. (Si la colonne C = Annulé ne pas prendre en compte le CA de la ligne).

Merci



1 réponse

Messages postés
12782
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 octobre 2020
2 046
Bonsoir

Si version Excel à partir de 2007 tu peux utiliser SOMME.SI.ENS:
=SOMME.SI(CLIENTS!B:B;CLIENTS!A:A;"24/10/2015";CLIENTS!C:C;"<>Annulé")

Si version antérieure :
SOMMEPROD(( CLIENTS!A1:A100=DATEVAL("24/10/2015"))*(CLIENTS!B1:B100)*(CLIENTS!C1:C100<>"Annulé"))
SOMMEPROD n'admet pas des plages par colonne entière (A:A ...)

Cdlmnt
Via
Bonsoir Via,

Merci pour ta réponse,

J'ai essayé avec la formule
=SOMME.SI(CLIENTS!B:B;CLIENTS!A:A;"24/10/2015";CLIENTS!C:C;"<>Annulé")

Le soucis c'est que la formule n'est pas bonne excel. Je pense que c'est au niveau du C:C il se met en surbrillance dans la barre de formule.

Et c'est bien =SOMME.SI ou =SOMME.SI.ENS ?

Merci
Messages postés
12782
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
22 octobre 2020
2 046 > Benny
Oui j'ai oublié le ENS à la frappe ! Il se fait tard !
=SOMME.SI.ENS(CLIENTS!B:B;CLIENTS!A:A;"24/10/2015";CLIENTS!C:C;"<>Annulé")
> Benny
Merci,

J'ai chercher avec ta formule j'ai enfin trouvé ma formule, la voici :

=SOMME.SI.ENS(B1:B4;A1:A4;"24/10/2015";C1:C4;"<>Annulé")

Merci beaucoup