Compter des cellules vides filtrés [Résolu/Fermé]

Signaler
Messages postés
5
Date d'inscription
mardi 1 janvier 2008
Statut
Membre
Dernière intervention
30 mars 2016
-
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
-
Bonjour,

Bonjour,

J'ai besoin de comptabilisé des cellules vides dans une colonnes que je viens de filtrer.
La fonction NBVAL ne prend pas en compte le filtre, la fonction sous.total ne permet pas de compter des cellules vides?
Merci d'avance.

4 réponses

Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 062
Bonjour,
Une solution, utiliser une colonne supplémentaire [C] avec la fonction SI() pour contrôler votre colonne avec les vides [B] soit :
=SI(B2="";1;"")

Et en [D1] la fonction :
=SOUS.TOTAL(2;C2:C13) 

Messages postés
5
Date d'inscription
mardi 1 janvier 2008
Statut
Membre
Dernière intervention
30 mars 2016

Bonjour et merci pour la réponse.
Malheureusement mon tableau fait déjà 200 colonnes. Donc la solution n'est pas envisageable.
Merci encore
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 062
Bonjour,
Ce qui est faux car vous avez 256 colonnes (2003) donc une colonne supplémentaire c'est possible.
Essayer pour voir...!
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 062
Bonjour,
Une autre possibilité est par exemple, la colonne [A] ne contient aucun vide (celle où vous avez le filtre) et la colonne [GR] est celle où vous voulez compter les vides.
Formule :
=SOUS.TOTAL(3;A2:A1000)-SOUS.TOTAL(3;GR2:GR1000)


Messages postés
5
Date d'inscription
mardi 1 janvier 2008
Statut
Membre
Dernière intervention
30 mars 2016

Bonjour,
Merci pour les infos. Concernant les colonnes, ce que je voulais dire, c'est que mon tableau utilise déjà environ 200 colonnes qu'il faudrait doublé. Avec 256 colonnes cela ne passe pas. De plus, bonjour le "poids" du fichier.
J'ai effectivement utilisé la formule =SOUS.TOTAL(3;A2:A1000)-SOUS.TOTAL(3;GR2:GR1000).
Merci encore.
Messages postés
9745
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
24 juillet 2020
1 062
Bonjour,
Merci de l'information.
Cependant cette solution par fonction n'a pratiquement pas d'influence sur la taille de votre classeur.
Salutations.
Le Pingou