Open office 4.0 et calcul conditionnel

Résolu/Fermé
Ptilu_Do - 18 oct. 2015 à 23:06
Raymond PENTIER
Messages postés
56113
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
- 20 oct. 2015 à 01:57
Bonjour,
je craque! Oo
cela fait plusieurs jours que je cherche une réponse en vain!!
J'ai un classeur OpenOffice dans lequel j'inscris plusieurs données, dans l'une de ses cellules le résultat est conditionné par le nombre y étant présent.

Pour être plus clair
J'ai une Cellule D19 contenant un nombre variable X, résultant de l'addition de 25 autres cellules.
dans D20 ce nombre X à un prix différents selon la quantité:
si X< ou = 12000 alors D20=D19*2
mais
si X> 12000 alors D20=((D19-12000)*1.4+24000)

comme ça, ça à l'air simple mais je ne m'y connait que peu sur ce logiciel et à chaque condition que je rentre je n'obtient que des erreurs ...

Quelqu'un pourrait il m'aider s'il vous plait?

Merci par avance



2 réponses

Raymond PENTIER
Messages postés
56113
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
17 208
Modifié par Raymond PENTIER le 19/10/2015 à 02:21
Bonjour.

La formule étant
=SI(D19<=12000;D19*2;(D19-12000)*1,4+24000)
je ne sais pas trop où tu t'es trompé, puisque tu n'as pas indiqué quelles formules tu avais essayées ! ...

C'est bien, la retraite ! Surtout aux Antilles ... :-)
Raymond (INSA, AFPA, CF/R)
0
Ptilu_Do
Messages postés
1
Date d'inscription
dimanche 18 octobre 2015
Statut
Membre
Dernière intervention
19 octobre 2015

19 oct. 2015 à 21:13
Bonjour Raymond et merci pour ta réponse rapide et exacte,
je pense avoir comprit mon erreur
pour commencer =SI(D19<=12000;D19*2 jusque là on est ok mais ensuite je suis reparti sur une suite avec ET(=si ....
en ajoutant des parenthèse pour les calcul prioritaire ...
Encore merci
0
Raymond PENTIER
Messages postés
56113
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 mai 2022
17 208
20 oct. 2015 à 01:57
Ah !
Il faut respecter scrupuleusement la syntaxe des fonctions, pour qu'elles marchent.
Pour la fonction SI il y a 3 arguments
SI( test_logique ; valeur_si_vrai ; valeur_si_faux )
Il n'y a donc pas lieu d'inventer autre chose, comme de remplacer le second point-virgule par ET(=SI ... et il n'y a pas de calcul prioritaire à l'intérieur d'une fonction !

Si tu veux en savoir plus, regarde les astuces (fiches techniques)
https://www.commentcamarche.net/applis-sites/bureautique/1515-utiliser-les-formules-de-base-dans-excel/
https://www.commentcamarche.net/applis-sites/bureautique/1511-utiliser-les-fonctions-si-et-ou-non-dans-excel/
0