Insérer des valeurs de cellule (des mots) dans une formule [Résolu/Fermé]

Signaler
Messages postés
18
Date d'inscription
jeudi 8 octobre 2015
Statut
Membre
Dernière intervention
13 octobre 2015
-
Messages postés
18
Date d'inscription
jeudi 8 octobre 2015
Statut
Membre
Dernière intervention
13 octobre 2015
-
Bonjour à tous,
voilà, j'ai fait un tableau avec des colonnes dans lesquelles apparaissent des noms qu'on choisi à l'aide d'une liste déroulante par exemple (PIERRE; PAUL; JACQUES).

A la fin de chaque ligne je voudrais faire la somme des fois ou les noms apparaissent.
Par exemple ligne 1 , il y a simplement pierre en (B1) et paul en (D1), je voudrais qu' à la fin de ma ligne mettons en (z1), apparaisse "2" pour dire qu'il y a deux nom sur cette ligne

De plus, je voudrais qu'il ne compte que les noms de cette liste (PIERRE; PAUL; JACQUES) et rien d'autre.
Merci pour votre aide!!!!

1 réponse

Messages postés
25329
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
5 505
Bonjour
pas sur d'avoir tout compris, voyez si eci peut vous servir:
à adapter

en Z1 à Z3 la liste des noms de référence à trouver:
et votre formule:

=SI(SOMMEPROD((NB.SI(D3;"*"&$Z$1:$Z3&"*"))*1)>0;1;"")

attention à tous les signes

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
18
Date d'inscription
jeudi 8 octobre 2015
Statut
Membre
Dernière intervention
13 octobre 2015
>
Messages postés
25329
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020

http://www.cjoint.com/c/EJjqtrsx634

C'est peut etre parce que les cellules sont remplies par des mots issus d'une liste déroulante non? Je vous envoie le fichier.
Par exemple dans la colonne : "nombre de matinées effectuées", je veux pouvoir comptabiliser le nombre de matinées ou une personne a été remplacée un matin.

Sur la ligne 3 donc,la personne ayant ete remplacée 2 fois (le lundi matin (D3) et le mardi matin(F")), j'aimerais voir apparaître le nombre 2 dans la cellule (N3)

Merci encore
Messages postés
25329
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
5 505 >
Messages postés
18
Date d'inscription
jeudi 8 octobre 2015
Statut
Membre
Dernière intervention
13 octobre 2015

Alors si votre tableau est complet, je ne vois pas pourquoi vous avez besoin de faire référence au nom pour trouver le résultat???..., puisqu'il suffit de compter le nombre de cellule comportant un nom entre D et L
soit donc:
=NBVAL(D3:L3)
crdlmnt
Messages postés
2108
Date d'inscription
vendredi 25 juillet 2014
Statut
Membre
Dernière intervention
30 septembre 2020
830 >
Messages postés
18
Date d'inscription
jeudi 8 octobre 2015
Statut
Membre
Dernière intervention
13 octobre 2015

Bonsoir
une proposition
en N3
=NB.SI(D3:L3;"<>"&B3)
Messages postés
25329
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 septembre 2020
5 505
Bonsoir yclik

votre proposition serait correcte:
__si toutes les cellules étaient remplies
__si la colonne B contenait le même genre de texte que le menu déroulant
Elle compte donc aussi les cellules vides et celle dont le nom n'est pas conforme à B, c'est à dire toutes
ce qui n'est pas le cas dans le modèle.
pour coller au modèle il faudrait écrire:
=NB.SI.ENS(D3:L3;"<>"&(A3&" "&B3);D3:L3;"<>")

Qui ne fonctionnerait dans tous les cas que si la concaténation A" "B correspond bien aux listes du menu

crdlmnt
Messages postés
18
Date d'inscription
jeudi 8 octobre 2015
Statut
Membre
Dernière intervention
13 octobre 2015

Bonjour et merci pour vos contrib
le problème c que =NBVAL(D3:L3) ne me suffit pas
En effet,
je veux dans une cellule (N44) comptabiliser le nombre d'occurrences de certains noms de ma liste déroulante (noms masculins par exemple) qui se trouveraient dans les cellules D44 F44 H44 I44 K44
Et dans une autre cellule (V44) je voudrais comptabiliser le nombre d'occurrences d'autres noms de ma liste déroulante (noms féminins par exemple) qui se trouveraient dans les mêmes cellules D44 F44 H44 I44 K44
Merci encore de votre aide