Renvoyer une cellule et sa mise en forme à une autre cellule

[Fermé]
Signaler
-
Messages postés
54894
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
-
Bonjour, j'ai besoin d'aide pour effectuer un petit travail sur excel:

j'ai 12 règles d'Or avec, pour chacune, le Titre, la Règle et le Picto qui va avec.
Pour faciliter le travail j'ai donc créé une liste déroulante semi automatique proposant le titre des 12 règles.
J'ai egalement fais une colonne de 12 cellules, regroupant dans chacune d'entre elle, le Titre, le Règle et le picto associé (en inserant un commentaire). Tout ceci avec la police souhaitée.

Mon problème: quand je choisi une des propositions du menu déroulant, je voudrai qu'il affiche automatiquement le Titre, la Règle et le Picto dans la même cellule. En gros qu'il affiche la cellule dans laquelle j'ai noté le titre, la règle et le picto de la règle choisie.


Est que quelqu'un sait comment je pourai faire? quelle formule je pourrai utiliser?



2 réponses

Messages postés
2940
Date d'inscription
vendredi 1 mai 2009
Statut
Membre
Dernière intervention
19 mars 2016
1 359
Bonjour,

A priori, je pense que l'on ne peut pas afficher autre chose dans ta cellule qui contient le menu déroulant.
Par contre rien ne t'empêche de créer une deuxième colonne qui te permettra de faire une recherche dans un tableau contenant la liste de tes règles et les informations que tu souhaites afficher, la recherche se faisant en fonction de ce que tu affiches comme règle.

Une formule telle que celle-ci te permettra de faire la recherche et d'afficher :

=SI(A2="";"";RECHERCHEV(A2;Regles!A$2:B$5;2))

A+

pépé
Messages postés
54894
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
16 804
Bonjour chrisandise.

"quelle formule je pourrai utiliser?" -> Il n'y en a pas. Il faut :
- soit suivre le conseil de pépé et y ajouter des règles de Mise en forme conditionnelle,
- soit écrire une macro en VBA.

Cordialement.
C'est bien, la retraite ! Surtout aux Antilles ... :-)
Raymond (INSA, AFPA, CF/R)