Doublons dans Excel

[Résolu/Fermé]
Signaler
-
 Denfer -
Bonjour,

Nous voici dans la période des budgets et je coince sur des doublons et je sollicite votre aide

Dans un tableau, j'ai la liste des projets et tâches qui est liée à un utilisateur et ensuite un coût
Voici un exemple

Projet A Task 1 Toto 9
Projet B Task 1 Toto 10
Projet A Task 2 Toto 11
Projet D Task 8 Toto 3
Projet A Task 1 Zozo 7
Projet A Task 1 Zozo 3
Projet B Task 1 Zozo 12
Projet A Task 2 Zozo 150
Projet D Task 8 Zozo 17

J'aurais besoin d'ajouter une colonne complémentaire pour me permettre d'avoir pour chaque personne une seule fois son prénom, les autres cases correspondant à son nom resteraient vides.
Exemple:

Projet A Task 1 Toto 9 Toto
Projet B Task 1 Toto 10
Projet A Task 2 Toto 11
Projet D Task 8 Toto 3
Projet A Task 1 Zozo 7 Zozo
Projet A Task 1 Zozo 3
Projet B Task 1 Zozo 12
Projet A Task 2 Zozo 150
Projet D Task 8 Zozo 17



Bien entendu, pour corser la chose, je ne peut utiliser la fonction doublons d'Excel puisque j'ai besoin à la fin de la somme des coûts pour chaque utilisateur. Mon fichier fait 10 000 lignes pour environ 250 personnes différentes alors je ne vois pas quelle formule utiliser et/ou quelles conditions utiliser.

J'espère avoir été clair

Merci d'avance pour votre aide

1 réponse

Messages postés
26122
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
30 juillet 2021
5 998
Bonsoir
si vos noms sont en E à partir de E2 (à adapter)
en F2:

=SI(NB.SI($E$2:E2;E2)>1;"";E2)

à tirer sur la hauteur

attention aux $

crdlmnt

Bonsoir Vaucluse,

Un tout GRAND merci pour votre aide sur cette formule qui fonctionne à merveille.

Je vous souhaite d'avance un excellent week-end

Denfer