HORAIRE

Résolu/Fermé
RIKOM Messages postés 1 Date d'inscription jeudi 10 septembre 2015 Statut Membre Dernière intervention 10 septembre 2015 - 10 sept. 2015 à 16:33
 Rikom - 17 sept. 2015 à 19:21
bonjour
je travaille sur un planning ,et je n'arrive pas à faire ceci:

heure actuelle en G9
5,13 et 21 sont les changements d'horaires
horaire actuelle
16h30
la formule
=SI(G9>5;"matin";SI(G9>13;"apres midi";SI(G9>21;"nuit")))
résultat : matin
se serait simpa si vous pouviez m'aider
merci

4 réponses

Zoul67 Messages postés 1959 Date d'inscription lundi 3 mai 2010 Statut Membre Dernière intervention 30 janvier 2023 149
10 sept. 2015 à 16:49
Bonjour,

C'est normal que le résultat soit matin puisque 16h30 > 5h...
=SI(ET(G9>=5/24;G9<13/24);"matin";SI(ET(G9>=13/24;G9<21/24);"après-midi";"nuit"))
avec G9 au format heure.

A+
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 403
10 sept. 2015 à 17:43
Bonjour

effectivement,Zoul le /124 est nécessaire mais pour faire plus simple, on peut placer dans l'autre sens pour éliminer les cas au fur et à mesure:

=SI(G9>21/24;"nuit";SI(G9>13/14;"après-midi";SI(G9>5/24;"matin";"")))


crdlmnt
0
Zoul67 Messages postés 1959 Date d'inscription lundi 3 mai 2010 Statut Membre Dernière intervention 30 janvier 2023 149
10 sept. 2015 à 17:55
à 1h du matin, je pense que le quart est "nuit"...
=SI(G9>21/24;"nuit";SI(G9>13/24;"après-midi";SI(G9>5/24;"matin";"nuit")))
+correction de faute de frappe.

ça me dérangeait de marquer deux fois "nuit". Question de goût...
0
Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022 6 403
Modifié par Vaucluse le 10/09/2015 à 18:06
Vi... tu as raison
reste à savoir si les gens peuvent commencer après minuit et ce qui se passe quand G9 est vide.
Crdlmnt
0
rikom > Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022
17 sept. 2015 à 09:09
bonjour,
merci d'avoir essayer.
la formule ne marche pas,tel que tu as écris la formule ,c'est le premier argument qui s'affiche "nuit" alors qu'il est 9h du matin , et c'est "matin" qui devrait être affiché.
à bientôt
rikom
0
rikom > Vaucluse Messages postés 26496 Date d'inscription lundi 23 juillet 2007 Statut Contributeur Dernière intervention 1 avril 2022
17 sept. 2015 à 11:42
horaire 3x8
0
via55 Messages postés 14426 Date d'inscription mercredi 16 janvier 2013 Statut Membre Dernière intervention 6 juin 2024 2 711
10 sept. 2015 à 16:50
Bonjour

Le mieux, poste un exemple de ton fichier sur cjoint.com, fais créer le lien, copies le et reviens l'indiquer ici dans un prochain message

Cdlmnt
Via
0
michel_m Messages postés 16603 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 16 décembre 2023 3 302
Modifié par michel_m le 17/09/2015 à 09:58
Bonjour,

Il faut partir en décroissant et non en croissant (l'après midi l'heure estt forcément supérieure à 5 et XL réagit a >5---> matin

si(G5>21;"nuit";si............."matin";"nuit")

"nuit" à la fin pour les heures de 0 à 5

le N/24 de mes petits camarades est à mettre si G5 est au format hh:mm

Michel
0
michel_m Messages postés 16603 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 16 décembre 2023 3 302
17 sept. 2015 à 12:11
désolé d'avoir dérangé Rikom en proposant une solution
0
ok on va essayer
merci
0
rikom > rikom
17 sept. 2015 à 16:30
=SI(D3>21;"nuit";SI(D3>13;"apres midi";SI(D3>5;"matin";"nuit")))
il est 16h 28
le résultat est nuit alors qu'il devrait afficher aprés midi
d3 est l'heure actuel
0
Zoul67 Messages postés 1959 Date d'inscription lundi 3 mai 2010 Statut Membre Dernière intervention 30 janvier 2023 149
17 sept. 2015 à 16:46
Bonjour,

Rikom, je crois que tu vas rendre Michel furieux.
Des messages du genre "ça marche pas" ne permettent pas de t'aider.
Merci de faire ce que via55 a demandé.
0
le lien a été creer

http://www.cjoint.com/c/EIrqmbt51n3
travail posté
0
Zoul67 Messages postés 1959 Date d'inscription lundi 3 mai 2010 Statut Membre Dernière intervention 30 janvier 2023 149
17 sept. 2015 à 18:41
Quand tu utilises "MAINTENANT", ce n'est pas qu'une heure, c'est date+heure.
Si tu mets au format nombre ou standard, tu as un nombre supérieur à 46000...

https://www.cjoint.com/c/EIrqPjHZhrJ
0
michel_m Messages postés 16603 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 16 décembre 2023 3 302
17 sept. 2015 à 19:00
Rikom
si tu te donnais la peine de lire la fin du message

le N/24 de mes petits camarades est à mettre si G5 est au format hh:mm
donc

=si(G5>21/24;"nuit";si............."matin";"nuit")
tu as la solution avec la pièce jointe de Zoul67 (bonjour)

bien que d'avoir l'ordi allumé 24:H/24 seulement pour voir l'heure et savoir si c'est la nuit ou l'après-midi peut paraitre pour le moins étrange

Et merci de tes remerciements pour le temps passé par 4 personnes pour t'aider
0
Rikom > michel_m Messages postés 16603 Date d'inscription lundi 12 septembre 2005 Statut Contributeur Dernière intervention 16 décembre 2023
17 sept. 2015 à 19:21
Mon ordinateur n'est pas allumer 24/24
C'est simplement que l'on m'à demandé de travailler sur un planning
Encore merci pour ceux qui ont bien voulu m'aider
0