RechercheH Equiv Index

[Résolu/Fermé]
Signaler
Messages postés
2
Date d'inscription
lundi 31 août 2015
Statut
Membre
Dernière intervention
31 août 2015
-
Messages postés
26236
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
-
Bonjour,

Comment faire pour afficher automatiquement le statut dans une colonne en fonction du type de courrier qui a été envoyé au client.
L'idée est d'avoir un suivi sur les courriers envoyés aux clients injoignables en commençant par un courrier simple puis une premier recommandé (LRAR1) puis un deuxième recommandé (LRAR2). Voir exemple ci dessous:

Client Statut Courrier simple LRAR1 LRAR2
Client 1 LRAR2 01/01/2015 01/02/2015 01/04/2015
Client 2 Courrier simple 15/08/2015
Client 3 Aucun

Merci pour votre aide!

Pierre

3 réponses

Messages postés
1953
Date d'inscription
lundi 3 mai 2010
Statut
Membre
Dernière intervention
12 août 2021
151
Bonjour,

Avec des SI imbriqués ?
=SI(E2<>"";"LRAR2";SI(D2<>"";"LRAR1";...

A+
Messages postés
2
Date d'inscription
lundi 31 août 2015
Statut
Membre
Dernière intervention
31 août 2015

Bonjour Zoul67,

Ça marche très bien!

Merci pour cette réponse rapide,

A +
Messages postés
13120
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 octobre 2021
2 266
Bonjour

En supossant tes données en colonnes A à E, en B2 la formule :
=SI(NBVAL(C2:E2)>1;"LRAR"&NBVAL(C2:E2)-1;SI(NBVAL(C2:E2)=1;"courrier simple";"Aucun"))
A étirer ensuite vers le bas

Cdlmnt
Via
Messages postés
26236
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
6 090
Bonjour
en variante si vous avez les titres de colonne de dates d'envoi en C1:E1 (ou plus si vous avez d'autres rappel)

=SIERREUR(INDEX($C$1:$E$1;EQUIV(MAX(C2:E2);C2:E2;0));"")

crdlmnt