Sommeprod avec conditions Excel 2010

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
jeudi 13 août 2015
Statut
Membre
Dernière intervention
13 août 2015
-
Messages postés
13209
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 décembre 2021
-
Bonjour,

Je suis nouvelle sur les forums et donc je ne suis pas une habituée des ces sites.

Ma question aujourd'hui concerne la fonction sommeprod.
C'est une fonction qui est nouvelle pour moi.
J'ai essayer de l'utiliser comme ceci :

=SOMMEPROD((B2:B623=E2)*(1/(NB.SI(A2:A623,A2:A623))))

mais ça ne fonctionne pas.


J'ai un fichier avec plusieurs livraisons sur différentes lignes avec différents code d'articles et quantités.
Cependant, la livraison peut se répété plusieurs fois.
Je veux connaitre le nombre de livraisons différentes (donc sans les doublons) avec comme critère les articles.

Le but à la fin étant de calculer une moyenne de quantité de produit par livraison.

J'aurais aimer inséré une pièce jointe avec une partie de mon fichier mais je ne sais pas comment faire et si c'est possible sur ce site.

Pour l'article 1 je sais qu'il y a 12 livraisons différentes (étaler sur 28 lignes) pour un total de 590 unités.
Je veux donc que le calcul soit 590/12 et non 590/28.
Ça fonctionne seulement si je prend juste de B2 à B30 (plage de l'article 1)

Est-ce qu'il y a une personne qui pourrais m'aider ?

Merci à l'avance

4 réponses

Messages postés
13209
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 décembre 2021
2 290
Bonsoir et bienvenue

pour joindre un exemple de ton fichier (tu as raison c'est plus efficace pour avoir une réponse), tu le postes sur le site cjoint.com, tu fais créer un lien, tu le copies et tu reviens le coller ici dans un prochain message

Dans l'attente
Cdlmnt
Via
Messages postés
3
Date d'inscription
jeudi 13 août 2015
Statut
Membre
Dernière intervention
13 août 2015

Bonjour,

Voici le lien avec le fichier en question.

https://www.cjoint.com/c/EHnrBx7zc4y

En espérant que j'ai réussi.

Merci :)
Messages postés
3
Date d'inscription
jeudi 13 août 2015
Statut
Membre
Dernière intervention
13 août 2015

Bonjour,

J'ai oublier de mentionner qu'ilfaudrait que la solution ne soit pas des filtres.

Il faudrait avoir un sommaire avec les différents articles.
Car je dois faire des comparaisons sur plusieurs mois et donc sélectionner article par article ne serait pas la meilleur solution pour mon besoin.

Merci
Messages postés
13209
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 décembre 2021
2 290
Bonsoir

Ce n'est pas SOMMEPROD qu'il faut utiliser mais FREQUENCE avec une formule matricielle :
Formule à mettre en H2 :
=NB(1/FREQUENCE(SI(B:B=E2;A:A);A:A))
Comme c'est une formule matricielle il faut la valider par CTRL+MAJ+Entrée, la formule se met alors automatiquement entre { }
A étirer ensuite vers la bas

Si tu veux en colonne E la liste des articles tu copies la colonne B, tu la colles en E puis en ayant la colonne E selectionnée tu vas onglets Données - Supprimer les doublons

Cdlmnt
Via