Fonction si absence d'une lettre

Résolu/Fermé
Signaler
-
Messages postés
17704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 décembre 2021
-
Bonjour,
Je cherche une formule me permettant d'afficher "NUL" dans une cellule en cas d'absence de la lettre U parmi d'autres lettres dans une autre cellule. Pouvez -vous m'aider? Merci


3 réponses

Messages postés
17704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 décembre 2021
4 857
Bonjour,

Essaye comme cela

=SI(NB.SI(A2;"*U*")=0;"NUL";"")

Merci pour votre réponse rapide,
la formule fonctionne mais comme je l'imbrique dans une formule plus longue j'ai encore quelques couacs entre les SI, les ET, les OU.

Dans la même lignée mais à l'inverse, je voudrais afficher "BIEN" dans ma cellule lorsque la lettre"U" est comprise dans A2 parmi d'autres lettres. J'utilise une fonction CHERCHE("U";A2) mais je pense que c'est elle qui pose problème.
Génial, merci encore pour votre aide précieuse! Je suis maintenant un peu moins nul sur Excel.
Messages postés
17704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 décembre 2021
4 857
Re,

essaye comme cela
=SI(NB.SI(A2;"*U*")>0;"BIEN";"")
Messages postés
17704
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 décembre 2021
4 857
Re,

Si tes attentes sont satisfaites, confirme le nous que l'on passe le statut de la discussion en résolu