Comparer deux chaines de caractere [Fermé]

Signaler
-
Messages postés
163
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
5 avril 2021
-
Bonjour,
Je cherche a comparer deux cellules dans deux colonnes excel.

Dans la premiere cellule j'ai : '' 2 Microsoft" et dans la deuxieme " Microsoft Tech".

Je souhaite avoir une formule ou une macro qui lorsqu'il trouve deux termes equivalents dans les deux cellules me renvois VRAI et s'il n'en trouve pas me renvois FAUX.

Je ne veux pas faire une comparaison en ciblant le mot Microsoft, je souhaite une formule plus generale.

Ce que j'ai tente et qui ne :

=IF(ISERROR(SEARCH(B2;A2;1))=FALSE;"VRAI";"FALSE")

=CHOOSE(COUNTIF(A2;"*"&B2&"*")+1;"False";"vrai")

Je vous remerccie d'avance pour toute l'aide que vous pourrez m'apporter.

3 réponses

Messages postés
33016
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
22 juin 2021
3 574
Bonjour,

Cela est possible par macro.

Une simple recherche sur le net permet de trouver facilement quelques exemples....

Par exemple :
https://www.developpez.net/forums/d1400057/logiciels/microsoft-office/excel/trouver-caracteres-cellules-ont-commun/


Je te remercie Jordan pour ton aide. J'ai quand meme fait des recherches en vain avant de poster ma question.
Je vais tester le link que tu'as fournis.
Messages postés
1978
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
28 septembre 2020
842
Bonsoir à tous,

Tu peux réaliser ce décompte à l'aide d'expressions régulières.
Personnellement, j'utilise l'addin Morefunc de Laurent Longre et ça donne :
=SOMMEPROD(--(REGEX.STXT(B5;"[^[:punct:]\s]+";LIGNE(INDIRECT("1:"& REGEX.NOMBRE(B5;"[^[:punct:]\s]+"))))=TRANSPOSE(REGEX.STXT(A5;"[^[:punct:]\s]+";LIGNE(INDIRECT("1:"& REGEX.NOMBRE(A5;"[^[:punct:]\s]+")))))))

(en supposant que les 2 cellules à comparer sont en A5 et B5).

Cette formule est à valider par CTRL+MAJ+ENTER.

Cordialement

NB :
1) J'ai du ajouter un espace entre l'esperluète et REGEX.NOMBRE( pour avoir un affichage correct de la formule entre les balises code.
Il faut les supprimer après le copier/coller.
2) Morefunc peut s'installer sur de l'excel 32 bits.
Merci, je vais tester cela de suite.
Messages postés
163
Date d'inscription
dimanche 9 mars 2014
Statut
Membre
Dernière intervention
5 avril 2021
5
Pourquoi ne pas faire " =a5=b5 "
si les données sont en a5 et b5,cela renvoie vrai ou faux