Formule pour récupérer une date dans un planning [Résolu/Fermé]

Signaler
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
-
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
-
Bonjour,
J'ai un calendrier horizontal où, pour chacun des 4 groupes que j'ai créé, je place une activité, marquée "R" dans l'exemple ci-joint : http://www.cjoint.com/c/EGjjeisDqUi

Pour l'instant j'ai marqué les dates manuellement.
Je cherche une formule pour "récupérer" automatiquement la date de l'activité, de façon à ce qu'elle figure dans la colonne marquée en jaune sur mon exemple.

Je suppose que je dois utiliser la fonction DECALER, mais je n'arrive pas à trouver la formule pour indiquer qu'il faut chercher, dans la ligne correspondant au groupe, la case marquée "R"...

Quelqu'un pourrait-il m'aider?

Dans mon exemple, l'activité a lieu seulement une fois par mois, donc ça ne doit pas être très compliqué... Bien sûr, si quelqu'un avait une formule pour récupérer plusieurs dates par mois, ce serait encore mieux (mais pas indispensable pour l'instant!).

Merci d'avance!

5 réponses

Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 356
Bonjour,

pas tout compris, en B2 ou tu as saisis R que veux tu la date de C1 02/07/2015
et en C13 la date que tu as en H107/07/2015, etc ... c'est cela !
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
1
Hmm, je n'ai pas été clair, en effet!

Dans mon exemple, j'ai saisi "R" en C2, H3, Y4, etc. Ce que je veux, c'est récupérer quelque part (dans mon exemple, en AG2:AJ5) les dates qui correspondent à mes "R": 2/7/2015 pour C2, 7/7/2015 pour H3, etc.

La formule en AG2, par exemple, doit repérer le premier "R" de la ligne "GROUPE 1", qui est en C2, et remonter d'une ligne pour trouver la date; puis en AH2, le "R" de la ligne "GROUPE 2", en H3, et remonter de deux lignes pour trouver la date, etc. Et idem pour les mois d'août et septembre...

Est-ce plus clair ainsi?
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 356
Re,

en AG2 colle cette formule et incrémente la jusqu'à AG5
=INDEX($B$1:$AF$1;EQUIV("R";B2:AF2;0))
pour AG7 modifie $B$1:$AF$1
par
$B$6:$AF$6

mais tiens tu à avoir les dates horizontalement AG2 pour le groupe 1 puis en AH3 pour le groupe 2 etc ...
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
1
A priori, je voulais avoir les dates du groupe 1 verticalement, en AG... Mais avec ta formule je vais peut-être réussir à me débrouiller! J'avais tourné "INDEX / EQUIV" dans plusieurs sens, mais sans parvenir à la faire fonctionner...

C'est déjà génial ainsi, en tous cas: merci. Si tu as une idée pour aligner en vertical les dates correspondant à chaque groupe, je suis preneur, mais sinon c'est déjà top.
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
1
Au pire, de toutes façons, j'adapte simplement la formule, sans l'incrémenter! En AG3, je mets: =INDEX($B$6:$AF$6;EQUIV("R";$B$7:$AF$7;0))
et c'est réglé!
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 356
Re,

essaye en AG2
=SIERREUR(INDEX($B$1:$AF$1;EQUIV("R";B2:AF2;EQUIV("GROUPE 1";A2;0)));"")
en AH2
=SIERREUR(INDEX($B$1:$AF$1;EQUIV("R";B2:AF2;EQUIV("GROUPE 2";A2;0)));"")

incrémente sur 5 lignes voir
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
1
En AG2, ça me sort la bonne date. Mais ensuite, si j'incrémente, les 4 cellules du dessous sont vides, et la cinquième sort la date en juillet (i.e. la formule va chercher la date sur la ligne 1, et non la ligne 6.

Mais je vois un peu ton idée.

En AH2, j'ai modifié ta formule pour l'adapter au changement de ligne (pour viser le groupe 2):
=SIERREUR(INDEX($B$1:$AF$1;EQUIV("R";B3:AF3;EQUIV("GROUPE 2";A3;0)));"")
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 356
Re,

je t'ai donné les formules pour AG2 et AH2 à incrémenter sur 4 lignes pour AG7 et les autres il faudra modifier les formules
l'idée est de mettre la date sur la ligne et colonne du GROUPE 1 puis GROUPE 2 etc ... et laisser les autres cellules vides
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
1
Ecoute, c'est vraiment parfait! Avec ça j'ai exactement ce qu'il me faut.
Merci de tout coeur -- aussi pour me faire découvrir "SIERREUR", que je ne maîtrise pas!
Messages postés
17297
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
30 octobre 2020
4 356
Re,

SIERREUR est utilisable depuis les versions 2007 avant il fallait tester la formule avec =SI(ESTERREUR( ce qui imposait de doubler la formule

si tes attentes sont satisfaites, je passe le statut de la discussion en résolu et part en vacance
Messages postés
39
Date d'inscription
dimanche 18 novembre 2007
Statut
Membre
Dernière intervention
24 mai 2017
1
Alors merci de toute cette peine! Et bonnes vacances!