Formule : Ne changer qu'une chose d'une cellule à l'autre

Fermé
Choupi0 - Modifié par Choupi0 le 8/07/2015 à 14:37
 Choupi0 - 8 juil. 2015 à 14:57
Bonjour,

Je suis novice sur excel et je ne parviens pas à faire la manipulation suivante :
Je vous simplifie le problème : j'ai un tableau qui doit calculer des quantités à partir de 2 autres tableaux.
La formule me permet de comparer 1 reference (0001) de produit avec toute une colonne de references differentes (liste des livraisons effectués), et si les 2 references sont équivalentes , alors les quantités de matières premieres correspondant à cette reference seront additionnées.
Reference recherchée : 0001

0002 | 4g
0012 | 5g
0001 | 7g
0002 | 4g
0001 | 5g

Resultat = 12g

J'ai donc la formule suivante (qui fonctionne dans mon tableur) :
Je veux mon résultat en D24
Si ma reference recherchée se trouve en B24
=SOM.ALS(I22:J100;B24;(K22:K100))-SOM.ALS(P22:Q100;B24;R22:R100)


Mon problème est le suivant : je dois donc incrementer ce B24 uniquement de facon à faire la recherche au meme endroit mais concernant une reference differente ,
or quand je fais glisser la formule de ma cellule de D24 à D25
j'obtiens
Formule D24 :
=SOM.ALS(I22:J100;B24;(K22:K100))-SOM.ALS(P22:Q100;B24;R22:R100)
Formule generée en D25 :
=SOM.ALS(I23:J101;B25;(K23:K101))-SOM.ALS(P23:Q101;B25;R23:R101)

Or je souhaiterai trouver un raccourci me permettant d'avoir :
=SOM.ALS(I22:J100;B25;(K22:K100))-SOM.ALS(P22:Q100;B25;R22:R100)

Afin d'etirer la cellule sur tous mon tableaux et que la recherche se fasse toujours sur la même plage de cellule
j'obtiendrais alors
=SOM.ALS(I22:J100;B25;(K22:K100))-SOM.ALS(P22:Q100;B25;R22:R100)

=SOM.ALS(I22:J100;B26;(K22:K100))-SOM.ALS(P22:Q100;B26;R22:R100)

=SOM.ALS(I22:J100;B27;(K22:K100))-SOM.ALS(P22:Q100;B27;R22:R100)...etc

Le tableau étant très long je ne peux pas le faire à la main...

Merci d'avance


1 réponse

ccm81 Messages postés 10508 Date d'inscription lundi 18 octobre 2010 Statut Membre Dernière intervention 1 décembre 2022 2 330
8 juil. 2015 à 14:55
Bonjour

Il te faut "bloquer" les références des plages comme ceci
D24=SOM.ALS($I$22:$J$100;B24;($K$22:$K$100))-SOM.ALS($P$22:$Q$100;B24;$R$22:$R$100)

Cdlmnt
0
Parfait! Merci beaucoup!
0