Somme par plage de données ?

Fermé
Ctac - 7 juil. 2015 à 18:40
Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 - 7 juil. 2015 à 22:42
Bonjour,
concrètement
en colonne A j'ai des articles tous différents les uns des autres
en colonne B j'ai un nombre d'articles vendus
en colonne C j'ai un numéro de page le même pour un certain nombre d'articles, pas toujours le même pour chaque page.

j'aimerai faire de manière automatique la somme du nombre total d'articles vendus pour chacune des pages.

J'espère que c'est assez clair

merci beaucoup pour votre aide



2 réponses

Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 062
Modifié par Mike-31 le 7/07/2015 à 18:47
Bonsoir,

Il aurait été bien d'avoir un exemple de fichier anonymisé pour te donner une formule adaptée
un exemple parmi d'autres
=SOMMEPROD((plage vendu=article)*(plage n°page=n°page))
tu peux joindre un exemple de fichier à partir de ce lien
https://www.cjoint.com/
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
0
voici l'idée http://www.cjoint.com/c/EGhtV7f6IyY
0
Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 062
7 juil. 2015 à 22:42
Re,

pour simplement faire faire la somme de page 3
=SOMME.SI(D2:D12;3;E2:E12)
pour page 4
=SOMME.SI(D2:D14;3;E2:E12)
etc ...
s'il faut prendre en compte deux critères exemple 1861AF et page 3
=SOMMEPROD((A2:A12="1861AF")*(D2:D12=3)*(E2:E12))
ou pour les versions récentes d'Excel
=SOMME.SI.ENS(E2:E12;A2:A12;"1861AF";D2:D12;3)

tu peux mettre les critères dans des cellules exemple l'article en E1 et le n° page en F1
=SOMMEPROD((A2:A12=E1)*(D2:D12=F1)*(E2:E12))
ou
=SOMME.SI.ENS(E2:E12;A2:A12;E1;D2:D12;F1)
0