Erreur dans formule Excel... [Résolu/Fermé]

Signaler
Messages postés
27
Date d'inscription
jeudi 12 avril 2012
Statut
Membre
Dernière intervention
2 juillet 2015
-
Messages postés
23406
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
3 août 2020
-
Bonjour,
J'ai un fichier Excel comportant plusieurs page et en tentant de modifier certaines formules (en changeant mes X en Y) car ma colonne à bouger de place, Excel supprime mes modifications et remets des X... pourtant, je fais la même chose avec mes autres formules et tout fonctionne... quelqu'un a une idée pourquoi? Et quand il accepte mes Y, j'obtient un message d'erreur (VALEUR)...
merci!

=SOMMEPROD((Masseréelle2015_2016!$C$8:$C$374="OuiHC")*(Masseréelle2015_2016!$Y$8:$Y$374))+SOMMEPROD((Masseréelle2015_2016!$C$8:$C$374="NewHC")*(Masseréelle2015_2016!$Y$8:$Y$374))+SOMMEPROD((Masseréelle2015_2016!$C$8:$C$374="NonHC")*(Masseréelle2015_2016!$Y$8:$Y$374))+SOMMEPROD((Masseréelle2015_2016!$C$8:$C$374="ADHC")*(Masseréelle2015_2016!$Y$8:$Y$374))+SOMMEPROD((Masseréelle2015_2016!$C$8:$C$374="XHC")*(Masseréelle2015_2016!$Y$8:$Y$374))+SOMMEPROD((Masseréelle2015_2016!$C$8:$C$374="XPHC")*(Masseréelle2015_2016!$Y$8:$Y$374))

3 réponses

Messages postés
23406
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
3 août 2020
6 276
Bonjour,

sans doute parce que tu as des valeurs non numériques dans ta colonne.
Mais sans fichier impossible de dire preécisément.

eric
Messages postés
25207
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
1 août 2020
5 387
Bonsoir
et bonsoir Eric ....qui a surement raison quant aux valeurs textes dans la colonne Y (qui peuvent venir par exemple de résultat de formule tel que "" ( à remplacer si possible par 0)
Ceci dit, il est possible avec une liste des 6 références à compter dans la colonne C , de réduire sérieusement la formule si par exemple vos inscrivez vos codes dans un champ nommé CODE (sans cellule vide, c'est plus sur):

=SOMMEPROD((NB.SI(CODE;Masseréelle2015_2016!$C$8:$C$374))*(Masseréelle2015_2016!$Y$8:$Y$374))

devrait l'affaire une fois les Y réglés!

principe ici:
https://www.cjoint.com/c/EGcubBvCRnB

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
27
Date d'inscription
jeudi 12 avril 2012
Statut
Membre
Dernière intervention
2 juillet 2015

Merci Eric! j'ai trouvé un = dans une cellule mais en blanc alors c'est pourquoi je ne le voyais pas. Merci à tous et bonne soirée! :)
Messages postés
23406
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
3 août 2020
6 276
Tu peux dire merci à vaucluse aussi.
eric