Formule Excel : somme condition date

[Résolu/Fermé]
Signaler
Messages postés
2
Date d'inscription
dimanche 28 juin 2015
Statut
Membre
Dernière intervention
28 juin 2015
-
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
-
Bonjour,

Je voudrais créer une formule Excel et j'aurais besoin de votre aide pour la réaliser.

Dans la colonne B j'ai des montants qui correspondent aux différentes dates de payement dans la colonne C. Je voudrais alors créer une formule qui pourra calculer la somme payée, c'est a dire qu'elle ne va pas prendre en compte le montant dont la date de payement n'est pas renseignée ou elle supérieure a la date actuelle.

J'espère voir été claire dans mon explication

Je vous remercie beaucoup par avance pour votre aide :)

2 réponses

Messages postés
54683
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
16 592
Bonjour et bienvenue.

Quand tu poses ce genre de question, il faut joindre ton fichier
(le vrai ou un fichier-exemple).
1) Tu vas dans https://www.cjoint.com/ 
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier (8192 Ko maxi)
3) Tu descends à la page suivante pour cliquer sur le bouton bleu [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en gras ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans ta discussion sur CCM, et dans ton message de réponse tu fais "Coller".
Voir la fiche https://www.commentcamarche.net/faq/29493-utiliser-cjoint-pour-heberger-des-fichiers
Cordialement.
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 059
Bonjour

pour Excel 2007 ou après
=SOMME.SI.ENS(B:B;C:C;">0";C:C;"<"&AUJOURDHUI())

Excel avant 2007:
=SOMMEPROD((C1:C1000>0)*(C1:C1000<AUJOURDHUI())*(B1:B1000))

N° de lignes dans les adresses de champ obligatoire pour cette formule

crdlmnt
Messages postés
2
Date d'inscription
dimanche 28 juin 2015
Statut
Membre
Dernière intervention
28 juin 2015

Merci beaucoup !!! ça a marché !
Messages postés
26192
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
22 septembre 2021
6 059
OK je passe le sujet en résolu
bonne route
crdlmnt