Comptabiliser des cellules en fonction d'un critére -Excel 2010

Résolu/Fermé
dav74
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015
- 8 juin 2015 à 13:56
dav74
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015
- 10 juin 2015 à 14:26
Bonjour,

Je souhaite Comptabiliser un nombre de cellules réparties sur 4 colonnes en fonction d'un critére.

Par exemple : date butée initiale en colonne I et date de clôture en colonne H
Si date de clôture >= à la date butée initiale alors compte 1 sinon pas comptabilisée.

Ensuite pour corser l'exercice j'ai 3 autres colonnes M (1er extention), Q (2eme extension) et U (3eme extention) dans lesquels peuvent figurer des dates d'extention par rapport à la butée initiale.

Merci de votre aide.

6 réponses

DjiDji59430
Messages postés
3608
Date d'inscription
samedi 19 avril 2008
Statut
Membre
Dernière intervention
10 août 2022
544
8 juin 2015 à 13:59
Bonjour dave74, et bienvenue,

Quand on joint un fichier-test, (avec TOUTES les explications) ou le fichier, c'est plus commode pour les intervenants. Et tu as plus de chances que quelqu'un s'intéresse à ton problème

1) Tu vas dans https://www.cjoint.com/
2) Tu cliques sur [Parcourir] pour sélectionner ton fichier
3) Tu descends en bas de la page pour cliquer sur [Créer le lien Cjoint]
4) Au bout de quelques secondes la deuxième page s'affiche, avec le lien en bleu souligné ; tu le sélectionnes et tu fais "Copier"
5) Tu reviens dans la discussion, et, dans ton message de réponse, tu fais : "Coller".

Cordialement.
0
Mike-31
Messages postés
18015
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
12 août 2022
4 966
8 juin 2015 à 14:28
Bonjour,

teste cette formule d'après ce que j'ai compris sur la ligne 2 et incrémente vers le bas, reste plus qu'à additionner les résultats

=SI(H2="";"";SI(OU(U2>=H2;Q2>=H2;M2>=H2;I2>=H2);1;""))
0
dav74
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

Modifié par dav74 le 8/06/2015 à 14:55
Voici le lien vers le fichier, Merci

http://www.cjoint.com/c/EFim26tQp6e
0
dav74
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

10 juin 2015 à 09:51
Bonjour,

Merci pour cette solution, mais elle est valable que pour une ligne. lorsque j'incrémente la formule vers le bas le resultat est toujours 1, ce qui ne devrait pas êre le cas.
Meri de votre aide
Cordialement
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 266
Modifié par Vaucluse le 10/06/2015 à 10:02
Bonjour
je n'ai pas compris tout à fait comme MIKE_salut l'ami_ (mais va savoir!)
si la de H2 est supérieure( donc plus tard) que la date butée des 4 cellules possibles, on renvoie 1 sinon rien
donc je verrais en ligne cette formule:
=SI(H2="";"";SI(MAX(I2;M2;Q2;U2)<H2;1;0))

mais ça reste à vérifier

crdlmnt

Errare humanum est, perseverare diabolicum
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
dav74
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

10 juin 2015 à 10:58
Bonjour, merci ça fonctionne pas tout à fait, la formule comptabilise 1 à chaque fois. même si la date est < à la date butée.

Merci
0
Vaucluse
Messages postés
26495
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 avril 2022
6 266
10 juin 2015 à 11:09
z'êtes sur?
voyez ici votre modèle en colonne A
(mais en fait il faut commencer avec la ligne 3)
https://www.cjoint.com/c/EFkjibR7KmX
crdlmnt
0
dav74
Messages postés
89
Date d'inscription
vendredi 22 mars 2013
Statut
Membre
Dernière intervention
21 octobre 2015

10 juin 2015 à 14:26
Ok, autant pour moi.

Merci beaucoup de votre coup de main
0