Formule SI + concatener si cela existe

Résolu/Fermé
Signaler
Messages postés
2
Date d'inscription
vendredi 22 mai 2015
Statut
Membre
Dernière intervention
23 mai 2015
-
Messages postés
2
Date d'inscription
vendredi 22 mai 2015
Statut
Membre
Dernière intervention
23 mai 2015
-
bonjour et déjà merci pour votre aide, je vais essayer d'etre claire en mettant un exemple !

Ma base de travail est un tableau de type 4 colonnes (A-B-C-D) et 3 lignes.
A/B/C/D
brice/brice/brice/cellulevide
gilles/gilles/cellulevide/gilles
guy/cellulevide/cellulevide/guy

je voudrai pouvoir obtenir dans une cellule les intitulés de colonne si la personne est identifiée dans la colonne.
voici le résultat que je souhaiterai.
Pour brice
A-B-C
Pour Gilles
A-B-D
Pour guy
A-D

merci pour votre aide

3 réponses

Messages postés
26310
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 décembre 2021
6 131
Bonjour
et salut Mike
Ca parait effectivement assez simplement, mais la solution que tu donnes ne tiens compte que de la première ligne, Gilles et Guy sont de sortie
si on essayait:
=SI(A1="";"";"A")&SI(B1="";"";"-B")&SI(C1="";"";"-C")&SI(D1="";"";"-D")
pour correspondre au plus près à la demande
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
17705
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 décembre 2021
4 857
Bonsoir,

cela me parait trop simple mais bon si ce n'est pas ça donne plus d'explications
formule pour la première ligne
=SI(A1="brice";"A";"")&SI(B1="brice";"-B";"")&SI(C1="brice";"-C";"")&SI(D1="brice";"-D";"")
Messages postés
2
Date d'inscription
vendredi 22 mai 2015
Statut
Membre
Dernière intervention
23 mai 2015

merci à vous 2, j'ai trouvé la solution en combinant vos propositions.