[C] textcolor ne fonctionne pas

Résolu/Fermé
Signaler
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
-
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
-
salut, je programme sous dev-c++. en incluant la librairie conio.h et en utilisant "textcolor(2);"(par exemple), le programme ne compile pas


==>

  [Linker error] undefined reference to `textcolor' 


que faire?

9 réponses

Messages postés
865
Date d'inscription
mercredi 17 août 2005
Statut
Membre
Dernière intervention
20 décembre 2012
187
salut ,

as-tu bien mis #include <conio.c> et non #include <conio.h> ?

sinon telecharge les library conio dezipe le et met les fichier dans \Dev-Cpp\include


Lien de telechargement library conio : http://fdr.free.fr/alldocs/1%20outils/O2%20console/conio.zip

a+
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
1
Date d'inscription
lundi 15 mars 2010
Statut
Membre
Dernière intervention
15 mars 2010
2
#include <conio.h> , déclare le de cette façon et ton problème est résolu
Tu dois déclarer la bibliothéque #conio.h au début , pour que sa fonctionne !! (j'espère que ça marchera pour toi)
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
54
..............
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
54
..............
Messages postés
1867
Date d'inscription
vendredi 15 avril 2005
Statut
Membre
Dernière intervention
24 juillet 2014
341
Bonjour,

Tu n'as surement pas déclaré la bibliothèque à ton compilateur.

Il faut ajouter les options -L<chemin_bibliothèque> -l<bibliothèque> à gcc.
Par exemple -L/usr/local/lib/libtextcolor -ltextcolor
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
54
je ne trouve pas la bibliothéque chez moi ça doit être ça...^^
tu ne saurais pas où la télécharger stp?
et aussi m'expliquer exactement où déclarer labibliothéqu au compilateur..

je te remercie d'avance..
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
54
euh non je n'avait pas mis conio.c, mais même en le mettant il ne trouve pas la librairie. J'ai donc téléchargé cette librairie grâce à ton lien et maintenant ça fonctionne ;)

merci
Messages postés
788
Date d'inscription
mardi 14 juin 2005
Statut
Membre
Dernière intervention
15 juin 2010
54
Ok merci à tous, cela fonctionne à présent.