Somme automatique

Résolu/Fermé
Signaler
Messages postés
10
Date d'inscription
jeudi 24 juillet 2014
Statut
Membre
Dernière intervention
17 août 2015
-
Messages postés
10
Date d'inscription
jeudi 24 juillet 2014
Statut
Membre
Dernière intervention
17 août 2015
-
Bonjour,
J'expose mon problème ,qui a je l'espère une solution .
dans ma feuille excel . j'ai deux colonnes ,
en A des nombres qui s'ajoutent tous les jours à la suite
exemple: A1 -> 12 ; A2 -> 25; A3 -> 3 ........ ect .... 365 jours par an
en B , je fais la somme de ces nombres en partant de A1 dans le style :
=somme($A$1:A1) et j'incrémente tous les jours .
Existe t'il un moyen d'automatiser (VBA éventuellement) ceci?
quand je tape en A mon chiffre , la somme se fasse automatiquement en B dans la cellule d'a coté sur la base de ma formule .

Cordialement


2 réponses

Messages postés
3544
Date d'inscription
dimanche 3 mai 2009
Statut
Membre
Dernière intervention
14 janvier 2022
1 047
Bonjour,

En changeant ta formule comme ceci

=SI(A1="";"";somme($A$1:A1))

que tu incrémentes dès de départ jusqu'à la ligne 365 tu n'as pas besoin de VBA ; les cellules de la colonne B resterons vides tant que tu ne renseignes pas la cellule A contiguë.

Cordialemet
0
Messages postés
10
Date d'inscription
jeudi 24 juillet 2014
Statut
Membre
Dernière intervention
17 août 2015

Bonsoir ,

Ta solution fonctionnes à merveille
Rapide et efficace

Merci Papyluc51

Cordialement
0