Formule Calcul Excel Somme.Si plusieurs critères

Résolu/Fermé
Signaler
Messages postés
95
Date d'inscription
jeudi 7 août 2008
Statut
Membre
Dernière intervention
29 décembre 2018
-
Messages postés
10189
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
2 décembre 2021
-
Bonjour,

Je souhaiterais savoir comment faire une formule avec plusieurs conditions, je pense que c'est une Somme.Si, mais j'arrive pas à trouver.

En gros, voici mon problème :

Colonne A = Segment - Colonne B = Prix - Colonne C = Remise sur segment 4W et TS - Colonne D = Remise sur autre Segment
4W - 4.84 € - 70 % - 65 %
TS - 5.86 € - 70 % - 65 %
2W - 6.87 € - 70 % - 65 %
MTC - 7.88 € - 70 % - 65 %
MAR - 8.89 € - 70 % - 65 %

J'ai besoin d'une formule qui me calcule : Si en colonne A j'ai 4W ou TS alors je prends le prix de la colonne B - la remise de la colonne C et si c'est un autre segment en Colonne A alors je prends le prix de la colonne B - la remise de la colonne D

Est ce faisable ?

Merci par avance pour votre aide.



4 réponses

Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
58
Salut,

Fichier : https://www.cjoint.com/c/EElpd0PFACr

Cdlt
Messages postés
10189
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
2 décembre 2021
2 253
Bonjour

En supposant qu'en C2 et E2 tu as le coeff. multiplicateur (et non le % de remise qui me semble bien gros)
E2=SI(OU(A2="4W";A2="TS");B2*C2;B2*D2)

Cdlmnt
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
58
Salut ccm81, c'est toi qui t'amuse à mettre des notes aux contributeurs ?
Messages postés
10189
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
2 décembre 2021
2 253
ça m'arrive, mais jamais en négatif !
Bonne journée à toi
Messages postés
95
Date d'inscription
jeudi 7 août 2008
Statut
Membre
Dernière intervention
29 décembre 2018
1
C'est exactement ça !
Merci beaucoup !

J'ai juste adapté la formule pour mes pourcentages, car j'ai mis mes 70 % donc ça m'enlevait juste 0.7...

Donc la dernière est la bonne :-)

Merci beaucoup à vous deux pour votre aide
Messages postés
589
Date d'inscription
mardi 7 avril 2015
Statut
Membre
Dernière intervention
23 juillet 2015
58
Re,

En y réfléchissant bien, je te propose de mettre cette formule en E8 d'après mon fichier et de l'étirer.

=SI(OU(A8="4W";A8="TS");B8-(B8*C8);B8-(B8*D8))

Cdlt