Relation nombre / texte

Résolu/Fermé
Signaler
Messages postés
30
Date d'inscription
lundi 20 avril 2015
Statut
Membre
Dernière intervention
2 mai 2016
-
Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
-
Bonjour,

Voila ma demande

J'ai une colonne avec des nombres et une deuxieme correspondant à du texte
Dans la feuille 2 en f2 il y a le nombre et en f32 je veux le texte correspondant dans la feuille 1

Si le nombre est renseigner en feuille 1 il faut ecrire son conditionnement en feuille 2 et si il n'y est pas il faut laisser la case en blanc donc " ".

voila le fichier
https://www.cjoint.com/c/EEeoByJT9Qp

Merci d'avance

1 réponse

Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
6 137
Bonjour
la formule en F32:

=SIERREUR(RECHERCHEV(F2;Feuil1!A:B;2;0);"")

mais pour que ça fonctionne il faudra accorder votre valeur en F2 avec ce qui est listé en A de feuil1

Dans votre modèle, la liste de Feuil1 en A présente des nombres, alors que Feuil2 F2 est un texte (il y a un blanc au milieu de la valeur)
Alors soit vous listez en A avec la même forme, soit vous formatez F2 en standard et retapez le N° sans blanc.
Mais pour l'instant, ça ne fonctionnera pas, même en enlevant le blanc, car le format reste en texte, et il faut entrer à nouveau le N°
crdlmnt
Messages postés
30
Date d'inscription
lundi 20 avril 2015
Statut
Membre
Dernière intervention
2 mai 2016

La cellule F2 arrive automatiquement en format texte je veux que le nombre en f2 soit chercher en feuil1 et que son conditionnement soit ecrit en f32

Que dois-je faire ?
Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
6 137
Si vous ne pouvez pas modifier votre liste en A de feuil1 pour qu'elle corresponde, essayez ceci qui devrait fonctionner, en numérisant la valeur F2 dans la formule (*1)

=SIERREUR(RECHERCHEV(F2*1;Feuil1!A:B;2;0);"")
Messages postés
30
Date d'inscription
lundi 20 avril 2015
Statut
Membre
Dernière intervention
2 mai 2016
>
Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021

c'est bon ca marche

Merci :)
Messages postés
26320
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 décembre 2021
6 137
Ok, je passe le sujet en résolu
Bonne route
Cdlmnt