Somme des doublons sur excel

[Résolu/Fermé]
Signaler
Messages postés
10
Date d'inscription
lundi 4 mai 2015
Statut
Membre
Dernière intervention
11 mai 2015
-
Messages postés
26245
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
-
Bonjour,

Je cherche à sommer les doublons sur excel mais je suis perdu ....

J'ai une feuille "client"
avec dans la colonne A "le point de vente"
colonne B "le type de produit acheté par le client"
colonne C " le numéro de la carte de fidélité du client"

colonne D " le montant du produit"

Par exemple
A:B:C:D
Paris: montre: 121345: 123
paris: montre: 1213145: 189
paris: sac à dos: 1213145: 500
Paris: montre: 1415189: 126
Lyon: oridinateur: 1413333: 890
Marseille: valise: 1213145: 100
Marseille: valise: 1213145: 158
Marsielle: valise: 1415189: 500
etc ...

J'ai envie de savoir comment calculer le montant total payé par le client pour chaque type de produit par endroit
Je vous remercie d'avance de votre aide que vous m'apportez. :D




4 réponses

Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 575
Personnelment, je ferais un tableau croisé dynamique à partir de ma table ^^

As-tu essayé ?
Messages postés
26245
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
6 093
Bonjour
si vous avez Excel au moins 2007:
formule en E 2à tirer sur la hauteur, si on commence en ligne 2

=SOMME.SI.ENS(D:D;A:A;A2;B:B;B2;C:C;C2))

vous placez entre guillemets les noms cherchés s'ils sont texte, sans guillemets s'ils sont numérique (N° de carte?)

cette formule vous donnera le cumul correspondant e n face de chaque ligne

si vous voulez un tableau récap, c'est un peu plus compliqué, sauf avec un TCD
Revenez si besoin

crdlmnt



Messages postés
10
Date d'inscription
lundi 4 mai 2015
Statut
Membre
Dernière intervention
11 mai 2015

àBRUCE Je n'ai pas très bien compris comment ça marche.....;

Mais merci comme même de ton aide :D

@VAUCLUSE Je vais essayer :D
Messages postés
11910
Date d'inscription
mardi 24 mai 2011
Statut
Contributeur
Dernière intervention
12 juin 2018
2 575
A qui réponds-tu : Vaucluse ou moi ?
Messages postés
10
Date d'inscription
lundi 4 mai 2015
Statut
Membre
Dernière intervention
11 mai 2015

@VAUCLUSE ça marche !!!!
Merci beaucoup de ton aide

ET merci aussi à BRUCE
Messages postés
26245
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 octobre 2021
6 093
en complément, une option avec édition de la liste récapitulative exhaustive (feuille récap)
https://www.cjoint.com/c/EEelF7vMVSu
crdlmnt