Recherche formule Excel [Résolu/Fermé]

Signaler
Messages postés
33
Date d'inscription
mercredi 18 juin 2014
Statut
Membre
Dernière intervention
11 août 2015
-
Messages postés
33
Date d'inscription
mercredi 18 juin 2014
Statut
Membre
Dernière intervention
11 août 2015
-
Bonjour,

Je vous pose mon problème :

Si Date Aller> Date J --> Excel me donne "0"
Si Date Aller<Date J et Date Retour<Date J --> Taux * Valeur * (Date Retour-Date Aller)/360
Si Date Aller<Date J et Date Retour >Date J --> Taux*Valeur*(Date J-Date Aller)/360

Date J : case A1
Date Aller : C24
Date Retour : D24
Valeur : E24
Taux :F24

Merci par avance

2 réponses

Messages postés
12793
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
28 octobre 2020
2 050
Bonjour Kaka

=SI(C24>A1;0;SI(D24<A1;F24*E24*(D24-C24)/360;F24*E24*(A1-C24)/360))

Mais le cas ou date Aller = date J n'est pas traité à part, mais peut être que c'est impossible

Cdlmnt
Via

1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
33
Date d'inscription
mercredi 18 juin 2014
Statut
Membre
Dernière intervention
11 août 2015

C'est parfait merci !
Messages postés
25453
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 octobre 2020
5 558
Bonjour

=SI(C24>A1;0;SI(D24<A1;F24*E24*DATEDIF(C24;D24;"d")/360;SI(D24>A1;F24*E24*DATEDIF(C24;A1;"d")/360;"")))

notez que avec la première condition, les C24 plus grands sont éliminés d'office, donc il est inutile de répèter <C24 dans les suivantes.
Par contre, avec ça vous appliquez les conditions si C24=A1. S'l ne faut pas écrivez:
=SI(C24>=A1;0;.................

crdlmnt