Test de présence de texte dans plusieurs cellule d'une colonne

Résolu/Fermé
Messages postés
17
Date d'inscription
mercredi 26 février 2014
Statut
Membre
Dernière intervention
5 avril 2017
-
Messages postés
17
Date d'inscription
mercredi 26 février 2014
Statut
Membre
Dernière intervention
5 avril 2017
-
Bonjour,

Je cherche à vérifier la présence du texte "TOUR" dans les cellules A46, A92, A138, etc. jusqu'à A1104, donc tout les 46 cellules, sur une feuille et, sur une autre feuille, afficher le résultat avec un texte et une couleur à l'intérieur d'une cellule. (Vert si ok, Rouge si non ok)

Auriez-vous des solutions ?

Merci d'avance.

2 réponses

Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
6 191
Bonjour
on ne voit pas très bien dans vos explications si vous voulez une liste des cellules avec le résultat, ou le nombre de cellules contenant le texte
pour la liste des cellules, champ en feuil1 et résultats en feuil2

feuil2, en A2, la formule:

=SI(INDIRECT("Feuil1!A"&(LIGNE()-1)*46)="texte");"OK";"")

et si votre texte peut se trouver inséré dans une texte plus long:

=SI(NB.SI(INDIRECT("Feuil1!A"&(LIGNE()-1)*46);"*texte*");"OK";"")

crdlmnt

Messages postés
17
Date d'inscription
mercredi 26 février 2014
Statut
Membre
Dernière intervention
5 avril 2017

Bonjour,

Je veux simplement vérifier que ce texte précis soit bien présent dans les cellules et pas un autre texte, si c'est un texte différent de celui recherché, le résultat est faux.
Messages postés
17
Date d'inscription
mercredi 26 février 2014
Statut
Membre
Dernière intervention
5 avril 2017

C'est simple :

Si le texte est bien équivalent à "TOUR" dans les cellules A46, A92, A138, etc. jusqu'à A1104 (dans la plage A1:1104) alors le résultat est vrai, si dans une des cellules le texte est différent de "TOUR", le résultat est faux.
Messages postés
26409
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
6 191
Alors essayez celle ci:
=SI(SOMMEPROD((MOD(LIGNE(A46:A1104);46)=0)*(A46:A1104="Tour"))=24;"VRAI")
crdlmnr
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 591
re
Il faut être précis dans la formulation : Je cherche à vérifier la présence du texte "TOUR" dans les cellules et maintenant si c'est un texte différent de celui recherché, le résultat est faux.
Dans le premier cas, tu as la présence de "TOUR" dans "la TOUR de Nimes" mais dans ta seconde formulation "le texte est différent".
Messages postés
17
Date d'inscription
mercredi 26 février 2014
Statut
Membre
Dernière intervention
5 avril 2017

Merci Vaucluse, c'est parfaitement ce que je veux.

gbinforme : J'essaie d'être le plus précis possible mais c'est pas évident de tout expliquer comme il faut la première fois.

Bonne journée à vous !
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 591
Bonjour,

Avec la fonction TROUVE tu peux le faire mais sans plus d'infos, je te laisse écrire la formule.