Problème formule

Résolu/Fermé
-
 bwarto -
Bonjour,

J'ai une formule sur Excel qu'il me semble bonne, mais une fenêtre s'ouvre pour me dire qu'il y a trop de caractère. Quelqu'un peut m'aider?

Voici la formule : =+SI($H20<$A$23;$B$21*(1-$C$22));SI(ET($H20>=$A$23;$H20<=$A$24);$B$21*(1-$C$23);SI(ET($H20>=$B$23;$H20<=$B$24);$B$21*(1-$C$24));SI($H20<=$A$25;B21*(1-$C$25)))

1 réponse

Messages postés
26411
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
27 janvier 2022
6 193
Bonjour
il ne doit pas s'agir de trop de caractères, mais plutôt de trop d'arguments?
en fait, vous pouvez enlever le signe + du début, mais le problème se situe en fait sur les doubles parenthèses qui suivent les calculs de chaque conditions et devraient en fait se trouver à la fin de la formule:
=SI($H20<$A$23;$B$21*(1-$C$22);SI(ET($H20>=$A$23;$H20<=$A$24);$B$21*(1-$C$23);SI(ET($H20>=$B$23;$H20<=$B$24);$B$21*(1-$C$24);SI($H20<=$A$25;B21*(1-$C$25)))))
crdlmnt

Errare humanum est, perseverare diabolicum
Super, merci beaucoup