Ecrire une formule à plusieurs condition [Résolu/Fermé]

Signaler
-
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
-
bonsoir a tous, s'il vous plait j'ai besoin de votre aide. en effet j'ai un tableau comme suit ci dessous :
NOM DATE NOTE
YAO 01/01/2015 4
LUCIEN 15/01/2015 1
FRANC 20/01/2015 8
LUCIEN 22/01/2015 2
CHRIS 23/01/2015 10
ARIANE 24/01/2015 12
LUCIEN 27/01//2015 15
AFFOUE 01/02/2015 0
LEO 15/02/2015 11
LUCIEN 20/02/2015 7

Je souhaite écrire une formule qui me permettra de calculer la performance de Lucien par mois selon les conditions suivantes :
1)il recherche toutes les cellules qui portent le nom de Lucien et qui sont compris du 01/01/2015 au 31/01/2015 en se référant à la colonne NOM et DATE
2)Il additionne les chiffres de chaque cellule de Lucien en se référant à la colonne NOTE et il le divise par ensuite par le nombre de cellule qui comporte Lucien du le mois à calculer dans une autre feuille nommé performance

Résultat : LUCIEN du 1/01/2015 au 31/01/2015 aura pour performance : (1+15+2)/3 = 6

aidez moi car je suis obligé de compter cellules par cellules nom par nom et cela est pénible surtout que un moi peut comporter 500 noms.s'il vous plait et excuser moi si j'ai pas été précis dans mes dits et merci

2 réponses

Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
810
Salut le Forum

Voir le lien : MOYENNE.SI

Mytå
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2
Merci MYTA , je visionne et j'essaie d'appliquer pour te donner la suite mais à vrai dire je suis profane sur excel
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2
au risque de te decevoir j'y comprend rien
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016
810
Re le Forum

En Colonne A : Les noms
En Colonne B : Les dates
En Colonne C : Les notes
En E4 : Lucien , en F4 : 01/01/2015 et en G4 : 31/01/2015

La formule (Excel 2007 et +)
=MOYENNE.SI.ENS(C:C;A:A;E4;B:B;">=" & F4;B:B;"<=" & G4)

Mytå
Messages postés
25428
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
24 octobre 2020
5 550
Bonjour
à adapter
nom de A1 à A1000
Date de B1 à B1000
note de C1 à C1000
en D1 entrer le nom cherché
en E1 entrer le N° du mois cherché

en F1 la formule

=SOMMEPROD((A1:A1000=D1)*(MOIS(B1:B1000)=F1)*(C1:C1000))
pour avoir le total des notes

et pour la moyenne:

=SOMMEPROD((A1:A1000=D1)*(MOIS(B1:B1000)=F1)*(C1:C1000))/ SOMMEPROD((A1:A1000=D1)*(MOIS(B1:B1000)=F1))

crdlmnt

Errare humanum est, perseverare diabolicum
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2 >
Messages postés
1206
Date d'inscription
vendredi 13 février 2015
Statut
Membre
Dernière intervention
29 juin 2020

merci pour tout
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2 >
Messages postés
2966
Date d'inscription
mardi 20 janvier 2009
Statut
Contributeur
Dernière intervention
20 décembre 2016

merci infiniment
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2
merci a tous pour votre aide!!!!!!!!!!!!!!
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2
Bonsoir à tous un merci pour votre aide sur le sujet passé mais s'il vous plait dites moi est ce que j'ai bien écrit la formule..
=SOMME.SI.ENS((Sheet1!K:K;E:E;">=01-janv.-15";E:E;"<=31-janv.-15"))/NB.SI.ENS((sheet1!K:K;E:E;">=01-janv.-15";E:E;"<=31-janv.-15"))
Messages postés
105
Date d'inscription
lundi 17 décembre 2012
Statut
Membre
Dernière intervention
28 août 2017
2
Encore mille merci à tous car j'ai pu grâce à vos réponses adapter des formules aux calculs qui se présentaient à moi encore merci à tous....