Dernière valeur d'une colonne strictement supérieur à 0 [Résolu/Fermé]

Signaler
-
 Natachaaaaa -
Bonjour,

Est-ce que quelqu'un connaît une formule permettant de renvoyer la dernière valeur d'une colonne strictement supérieur à 0 ?
Je m'explique j'aimerais la dernière valeur de ma colonne F mais les deux dernières valeurs sont 0 et - 147 j'aimerai une formule qui me renvoie la valeur précédant ces deux valeurs qui elle est positive.

Merci

Natacha

3 réponses

Messages postés
25215
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
13 août 2020
5 403
Bonjour
on cherche, mais en attendant de trouver mieux, une solution en deux temps
si votre champ commence en F2 et va jusqu'à F100 (à adapter), une formule en G2 à tire sur la hauteur:(ou dans une colonne masquée ou sur une autre feuille)
=SI(OU(F2<=0;NB.SI(F3:$F$100;">0")>0);"";1)
attention aux signes $ sur $F$100 seulement
et en G1
=INDEX(F:F;EQUIV(MAX(G:G);G:G;0))

on cherche en une seule formule
à +
crdlmnt

Messages postés
16177
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
14 août 2020
3 003
Bonjour
colonne A24 avec plusieurs passage à O oumoins, donne la dernière valeur au dessus de la valeur <=0
=INDEX(A1:A24;MAX(SI(A1:A24>0;LIGNE(A1:A24)))-1)
Formule matricielle à valider par « ctrl+maj+entrée » (et non directement par « entrée »), le curseur clignotant dans la barre de formule

Michel
Messages postés
14934
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
24 juin 2020
4 112
Bonjour Michel,

Belle formule comme d'habitude, mais je crois que tu as laissé trainé un -1 intempestif
=INDEX(F:F;MAX(SI(F:F>0;LIGNE(F:F))))
en colonne F comme demandé.
Merci beaucoup sans le -1 la formule fonctionne parfaitement !
Bon week end !

Natacha