Excel : compter un nombre de ligne avec des conditions

[Résolu/Fermé]
Signaler
-
 jdal -
Bonjour,
Je recherche actuellement un moyen de compter un nombre de ligne sur une colonne entière avec des conditions.
J'ai trouvé pour cela la fonction NB.SI.ENS cependant je n'arrive pas à appliquer ma condition. J'ai recherché sur des forums en vain.

Voici mon problème :
J'ai une colonne A sur laquelle j'ai un entête sur la première ligne et des entiers sur les suivantes. J'ai une colonne B construite de la même manière.
Je souhaite compter le nombre de ligne de la colonne A qui ont un entier supérieur à celui de la colonne B.

J'ai donc essayé ceci : =NB.SI.ENS(A:A;">" &B:B )
mais sans succès...

Si quelqu'un connait la solution de mon problème je suis preneur.

Merci d'avance
A voir également:

1 réponse

Messages postés
26242
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
23 octobre 2021
6 090
Bonjour
essayez avec, si vous avez besoin de 1000 lignes
=SOMMEPROD((A2:A1000>B2:B1000)*1)
crdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41713 internautes nous ont dit merci ce mois-ci

Merci c'est exactement ce que je recherchais !!! J'ai foncé tête baissé sur le NB.SI.ENS au lieu de chercher une autre fonction ^^
Et si je souhaite mettre 2 conditions ? Par exemple j'ai une colonne C sur laquelle il est marqué "vrai" ou "faux" et je veux compter la ligne seulement si celle-ci est marquée vrai. J'ai essayé
=SOMMEPROD((ET(A2:A1000>B2:B1000;C2:C1000="vrai"))*1)
Mais sans succès as tu une idée ?
Une solution est d'effectuer un produit de matrices:
=SOMMEPROD((A2:A1000>B2:B1000)*(C2:C1000="vrai")*1)